Mac Pro always boots Win8.1 regardless of preselected startup disk

Discussion in 'Windows, Linux & Others on the Mac' started by ActionableMango, May 13, 2015.

  1. ActionableMango, May 13, 2015
    Last edited: May 13, 2015

    ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #1
    I have three separate boot disks:
    • Disk 0 Windows 8.1 (EFI)
    • Disk 1 Windows 7 (GPT)
    • Disk 2 OS X Yosemite (HFS)
    I have tried the following methods to select the startup disk, all of which boot 8.1 regardless of selected disk:
    • In OS X using Startup Disk
    • In OS X using Bootchamp
    • In Windows 7 using Bootcamp Utility
    • In Windows 8.1 using Bootcamp Utility
    The following method does work--at boot time, holding the option key and selecting any OS will boot that selected OS. This method is not preferable to me because it takes so long.

    Prior to adding Win8.1 to the mix, I could select any OS from anywhere and it would work fine. Anyone know how to fix this?
     
  2. Naio macrumors member

    Naio

    Joined:
    Apr 2, 2015
    #2
    Have you tried to reset your computer's PRAM?

    https://support.apple.com/kb/PH18761
     
  3. ActionableMango thread starter macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #3
    No. :eek:

    I have to admit that there's a tiny part of me that hopes this won't fix the problem. Because if it does, I will have to slap myself in the face.

    Thanks. Will try tonight.
     
  4. ActionableMango thread starter macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #4
    Worked.

    Thanks.

    Slapped myself in the face too.
     
  5. Naio macrumors member

    Naio

    Joined:
    Apr 2, 2015

Share This Page