Mac Pro and Dell U2311H Weirdness

Discussion in 'Mac Pro' started by FluJunkie, Feb 23, 2011.

  1. FluJunkie macrumors 6502a

    Joined:
    Jul 17, 2007
    #1
    So, I've got a new 2010 Mac Pro with the ATI 5870, and right now, I'm thrilled with it. It's hooked up to a Dell U2311H display, and I'm having an odd problem.

    Hooked up from the DVI port on the video card to the DVI port on the display, everything is fine.

    Hooked up from the Mini DisplayPort on the video card to the DisplayPort on the display, things seem alright until something happens, like the computer going to sleep, or being turned off. Then, on startup, the screen will remain blank, and the display assets no signal is coming from the computer. As far as I can tell, the only way to fix this is to shut down the computer and switch back to the DVI port.

    Any idea what's going on?
     
  2. dimme macrumors 65816

    Joined:
    Feb 14, 2007
    Location:
    SF, CA
    #2
    What type of mini displayport to displayport cable are you using? I have a similar problem on my MacPro & Dell U2410. All is well unless I turn off the monitor at the power button. It will not turn back on until you unplug the power and display port cable. On the Dell forms many people have this problem and some think it is due to improperly made cables. They say if you buy the apple minidisplayport to displayport adapter and use the Dell cable all is well. I have not tried it I just went back to DVI. I used a cable from monoprice.com.
     
  3. TheDoc macrumors member

    Joined:
    Mar 18, 2008
    #3
    I have the same monitor and was experiencing similar problems.

    I have programs running 24/7, so the machine never sleeps which I know some people have said can be a problem (upon waking from sleep monitor will not work).

    My fix was to unplug the power of the monitor and plug it back in. The problem seems to have sorted itself out - so I'm not much help, I'd imagine.

    I do have a lot of static sometimes, so I've got my cable hooked up on top of the monitor. I have a feeling it's just a faulty adapter cable. I'm going DVI > MDP.
     
  4. Vylen macrumors 65816

    Joined:
    Jun 3, 2010
    Location:
    Sydney, Australia
    #4
    I had pretty much the problem as described by the OP along with a couple other people here some time ago. the problem was a dodgy cable or something - even though we bought our cables from different places, they were the same ones (for reference they are ones sold from monoprice). It was solved for all of us by buying the MDP to DP cables from Circuit Assembly.

    You might find the original thread where we discussed this by searching for "Circuit Assembly"
     

Share This Page