Mac Pro and Highpoint 4310. PLEASE HELP!

Discussion in 'Mac Pro' started by GHF7, Feb 17, 2011.

  1. GHF7 macrumors newbie

    Joined:
    Sep 24, 2010
    #1
    Hello Every one,

    Here is my problem...

    I installed a Highpoint 4310 into my Mac Pro. I already have a 4322 in there.
    After the installation everything looked good, system profile was showing all the cards and that the drivers where working.

    I was able to load the web management and saw both cards in there. This is where the problem started...

    I am trying to set my 4310 up as my bootdisk ( 4x 1TB Drives ) So I had to flash the card with the bootable EFI. For some reason I could not find the 4310 EFI so I used the 4311 ( since its the same card just external port unlike the internal port of the 4310 )

    After I did that and rebooted the system the card no longer shows up in the web management. It does show up in System Profile but says NO for driver installed....

    I took the card out and put it into my PC and was trying to figure out how to use the flashelf.exe but had no luck.

    If any one could give me the proper step by step to use the flashelf.exe that would be AMAZING!!!!

    otherwise any help to get this card back to its original state would be so appreciated!

    thank you!
     
  2. GHF7 thread starter macrumors newbie

    Joined:
    Sep 24, 2010
    #2
    Does anyone know how I can contact a user on these forums?
    I came across some post that dealt with the exact problem I am having. I want to sent a PM to the user but cant seem to find a way to do this.


    Thanks!
     
  3. oscis macrumors newbie

    Joined:
    Sep 24, 2008
    Location:
    UK
    #3
    Hi GHF

    I might be able to help. Which step isn't working for you below:


    To recover:

    - Get the card into a pcix slot of a Windows box
    - Download windows firmware for your card
    - Read firmware release notes and instructions for flashing the BIOS!
    - Make a DOS bootable memory stick so you can boot directly into real DOS. The command prompt will not save you here.
    - Copy all Windows firmware and flsahelf for the 4320 onto your DOS memory stick
    - Configure your Windows box to boot from USB... and boot into DOS
    - Flash the Raid card
    - Change your BIOS and boot back into Windows
    - download this: (same link as in quoted text) http://www.highpoint-tech.cn/BIOS_Dr...EFI-081113.zip
    - Install (or re-install) Windows Highpoint drivers
    - Use the in-band GUI to check the card is now recognised.
    - Use the in-band GUI to flash firmware with the RR4320-EFI-081113 linked above.
    - Get the card back in your MAC, sigh a sigh or relief as it boots


    Cheers

    Tom
     
  4. GHF7, Feb 19, 2011
    Last edited: Feb 19, 2011

    GHF7 thread starter macrumors newbie

    Joined:
    Sep 24, 2010
    #4



    Hey, Thanks so much for getting back to me.

    Im stuck on flashing the card. I placed the card into a PC. I made a bootdisk using a floppy and placed the 4310bios.blf file in there and also the 4310fw.blf file.

    So once DOS starts "A:\>" I type flashelf.exe [4310bios.blf]

    This is what I get back-
    Highpoint flashelf for DOS (built at Apr 02 2009 16:16:05)

    Found adapter 0x43111103 at PCI 3:0:0
    Flash is Intel Strata
    Can't open file

    I cant figure out what "Flash is Intel Strata" means and how I can get past this.

    :(
     
  5. oscis macrumors newbie

    Joined:
    Sep 24, 2008
    Location:
    UK
    #5
    I wouldn't worry about that - I think it's just describing the flash media.
    Its the next error that matters..
    I personally would double check that you've downloaded the Windows firmware and that your booting into a DOS environment.
    Then try flashing with the firmware file itself, 4310fw.blf.
     
  6. GHF7 thread starter macrumors newbie

    Joined:
    Sep 24, 2010
    #6

    How do I know if I'm booting just in to DOS? I mean I feel like I am.
    I'm pretty sure that I did download the correct files. :(
     
  7. GHF7 thread starter macrumors newbie

    Joined:
    Sep 24, 2010
    #7
    Ahhh!!! getting really sick of this...

    So I downloaded a Driver Free Disk For BIOS Flashing from bootdisk.com.
    I placed the files for the bios and firmware on the floppy drive and still get the same message - Can't open file - wtf? I tried the 4311 files the 4310 files and still nothing!
     
  8. oscis macrumors newbie

    Joined:
    Sep 24, 2008
    Location:
    UK
    #8
    Sorry GH, I'm not sure where you can go from here.

    It does sound like either flashelf can't read the firmware files on the floppy or can't read the files on the raid card. Maybe try a fresh download of the files, a different floppy or even booting from USB would help.

    Without being in front of the box there's not a lot more I can suggest.. other than trying to speak with Highpoint themselves?
     

Share This Page