Mac Pro display gone screwy

Discussion in 'Mac Pro' started by rickruss, Jul 15, 2010.

  1. rickruss macrumors newbie

    Joined:
    Jun 14, 2010
    #1
    I have a two-year-old Mac Pro with 16GB RAM, an OEM Apple video card driving an aluminum enclosure 30" Cinema display. I just upgraded to Snow Leopard about two weeks ago and have the latest updated version. Over the past two weeks, when I occasionally leave the Mac unattended I would come back and the picture would be "jumbled" where I could still make out the windows and icons, but there was an abundance of color noise all around. Up until yesterday, a restart would correct the issue.

    Last night I restarted after the picture did the same thing, only the screen diplayed a patterned gray background and never recovered. I could hear the drives cranking inside the box and it sounded like it was booting up properly. A couple of times (I tried to correct it by restarting several times) the pattern displayed and the screen went black - only the kind of black where you can tell the monitor is on.

    To me, it sounds like my video card might have given up the ghost, but I wanted to the counsel of the gurus before I started making investments. Any help or insight is appreciated. Thanks in advance!
     
  2. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #2
    Do you have a cheap Apple video card that you could test it with? Also, try the display with another computer to rule that out.
     
  3. rickruss thread starter macrumors newbie

    Joined:
    Jun 14, 2010
    #3
    I only have the video card I used for a 23" display...I doubt if it would push a 30" monitor.
     

Share This Page