Mac Pro (Early 2008) Freezes on Wake from Sleep / Display Won't Come On (Solution)

Discussion in 'Mac Pro' started by Harpo, Oct 28, 2009.

  1. Harpo macrumors member

    Joined:
    Jun 23, 2006
    #1
    This seems to be a common enough problem: Mac Pros, Early 2008 with the ATI Radeon HD 2600 XT card, have one or both of the following problems:

    1. On wake from sleep, display won't light, or lights but the screen is frozen, except for the mouse which can be moved.
    2. On power on or restart, display doesn't light, but the computer boots and is functional. This happens frequently, but not always; shut it down for a while, possibly reset the PMU or reseat the graphics card, and start it back up enough times, you'll get your display back eventually, but as time goes on the problem becomes worse and worse until finally nothing brings it back to life.

    The problem is with the ATI Radeon HD 2600 XT, and the consensus online is that the thing is defective and needs replacement. Replacing the card will fix the problem.

    However, I think I may have fixed it without a new card--naturally the day after I ordered one. Since the computer still runs without the display, you'll have to VNC/Screen Share/Remote Desktop in. If none of that is enabled, perhaps someone knows how to enable it blind; otherwise, I guess you'll have to wait until the display decides to light, or, if Remote Login is enabled, send the needed files over, perhaps put them on a USB stick, and execute the terminal commands via ssh.

    Anyhow, here's the method (Do this ONLY on a Mac Pro with a Radeon HD 2600 XT, and at your own risk):

    1. Download the Radeon HD 2600 XT firmware update: http://support.apple.com/kb/DL110

    2. Download unpkg: http://www.macupdate.com/info.php/id/16357/unpkg

    3. Using unpkg, extract the package in MacProGraphicsFWUpdate.dmg (called MacProGraphicsFWUpdate.pkg)

    4. Go to terminal and change your working directory (cd) to MacProGraphicsFWUpdate/Applications/Utilities/ATI Radeon HD 2600 XT Firmware Update.app/Contents/Resources
    (This is NOT in your regular applications folder; it's wherever unpkg extracted to.)

    5. Type these terminal commands, entering your password for sudo:

    sudo chown -R root:wheel ATIROMFlasher.kext
    sudo chmod -R 644 ATIROMFlasher.kext
    sudo kextload ATIROMFlasher.kext
    sudo open ATIFacelessFlash.app
    (Let ATIFacelessFlash run until it closes; it should appear in the Dock, and for me it went very fast.)
    sudo kextunload ATIROMFlasher.kext

    That's it. Now restart and see if things work. I make no guarantees; I haven't been testing it long enough to tell if this really worked, or if the card just decided to work and will fail again soon. But the moment I did this, the card came back, after a day of reseating and restarting and resetting the PMU, which used to work but no longer did, and I cannot reproduce any of the original problems.
     
  2. Mhaddy macrumors 6502

    Mhaddy

    Joined:
    Oct 26, 2005
    Location:
    Canada
    #2
    Good to know as I was having this same issue and as I was covered under AppleCare, decided to opt for a replacement card. Just came in the mail yesterday so I plan to install & test tonight; will update my linked post with the results but this is good to know if that doesn't work.

    Are you running Leopard or Snow?

    Edit - Put the new card in last night and I've got my display back. For anyone experiencing the same issue as described in this thread - get on the phone with Apple and get a replacement card! Problem solved.
     
  3. Harpo thread starter macrumors member

    Joined:
    Jun 23, 2006
    #3
    Snow Leopard. Under Leopard, the problem was the same, except the screen did not light at all upon wake. Under Snow Leopard the screen lights but is frozen except for the cursor.
     
  4. Harpo thread starter macrumors member

    Joined:
    Jun 23, 2006
    #4
    Card died again about a week later, flashing again (if it even flashed the first time) was not effective. Guess the thing really is defective. Oh well, GT120 it is. It seems the GT120 is a little slower than the ATI 2600 XT, is that true?
     
  5. Mhaddy macrumors 6502

    Mhaddy

    Joined:
    Oct 26, 2005
    Location:
    Canada
    #5
    Not sure about that - never had the GT120. Sorry to hear about your luck!
     

Share This Page