Mac Pro (early 2009) won't recognize internal drives.

Discussion in 'OS X Mavericks (10.9)' started by MrNiv, Oct 26, 2013.

  1. MrNiv, Oct 26, 2013
    Last edited: Oct 26, 2013

    MrNiv macrumors newbie

    Joined:
    Oct 26, 2013
    Location:
    Southern California
    #1
    Ok, this one is a puzzler. If anyone out there has any ideas at all, I'd be very grateful.

    I have a Quad-Core Mac Pro (early 2009), 6gb stock factory RAM, ATI 5770, and a 1TB internal hard drive. Current OS is Lion, 10.7.5.

    So… I downloaded and tried to just 'upgrade' to Mavericks the other day. The installer downloaded fine, launched, and ran. At the end of the install, it restarted the machine as per usual. When it tried to restart however, it would go from the Apple logo boot screen to the "Prohibitory Sign" (circle with a slash through it) screen and just hang there.

    Figuring that a clean install was probably the order of the day, I was able to boot from my original Install DVD (Snow Leopard). I ran Snow Leopard through software update a couple times and downloaded the Mavericks installer again. It launched, ran, and rebooted the machine.

    No dice, it tries to load and gives me the same prohibitory sign nonsense that happened before.

    FINALLY, I was able to instal Mavericks on an external Firewire drive, and boot the machine from that. I ran Disk Utility and my internal hard drive is just not there… not even listed. So I go to About This Mac and run the system report… and there is NOTHING listed under SATA. No drive at all.

    I know the drive is not physically broken, because I'm using it right now. I was finally able to boot from the DVD's and restore a pre-Mavericks Time Machine backup. But this is just driving me nuts. Why would Mavericks not see a perfectly good functioning internal Hard Drive?
     
  2. mrhoaf macrumors newbie

    Joined:
    Dec 4, 2013
    #2
    Same System, same problem

    I'm working on a Early 09 Mac Pro for a friend with the exact same issue.

    Did you find a fix?
     

Share This Page