Mac Pro fails to start completely

Discussion in 'Mac Pro' started by FireArse, May 26, 2007.

  1. FireArse macrumors 6502a

    Joined:
    Oct 29, 2004
    #1
    Hi all,

    While browsing, I noticed my mac pro not open any more Apps. Funny I thought. I'd better restart. It hung after it closed all the programs with the spinning disc (not beachball) still spinning for 10 odd minutes.

    I turned it off by pressing the power button for the 7 odd seconds or whatever.

    Restarted, and got a black screen with a UNIX terminal style screen with:

    CSRHIDTransitionDriver::stop
    -sh: /etc/profile: is a directory
    IOBluetoothHCIController::start Idle Timer Stopped
    -sh-2.05b#

    Tried Hardware Test, nothing, even in advanced mode. It started in Target Disc mode, it started up the Apple Installation Disc.
    I think it has something to do with bluetooth (and I do have bluetooth) but I don't wanna rip out the Bluetooth card myself...

    Any ideas people? AppleCare UK lines were closed - so I called AppleCare USA and the guy there thinks it might be a faulty Logic board - but why would it start ok in Installation mode if the logic board was screwed?

    Standard Mac Pro 2.66 with Bluetooth added in Brent Cross. No problems since purchase in September.

    Thanks

    F
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Is the Bluetooth card a third party option or was it the Apple card? Considering it's still under warranty, I reckon it's probably better to take it in to get fixed by a certified repairer. Back up your data with Target Disk Mode first though. Good luck. :)
     
  3. FireArse thread starter macrumors 6502a

    Joined:
    Oct 29, 2004
    #3
    After a visit to a Mac Genius...

    So I booked an appointment with a Mac Genius. He looked at it, and said, something is wrong with a startup file. Confirmed my hardware was OK by starting up another OS X drive - worked fine.

    So he set about re-installing the 10.4.9 update.

    Cool, except it took an awfully long time, like 13 minutes or so. My eyebrows were raised, but fair enough, it did its thing and we rebooted.

    Except the only drive we were able to boot from, was the FW drive. 'Oh crap' the Genius said.

    Crap? Crap?! WTF does that mean? Bye bye HDD? Bye bye data?

    So he starts up again in FW mode and lo and behold, my HDD was wiped. Not exactly his fault. My last backup was about a month ago - lost some files & photo's but generally no big deal.

    He replaced my HDD and sends me on my merry little way. I tell him I want my old drive '7-pass' erased, and he tells me once is enough. I tell him again I wanted it done 7 times (since he was so competant at wiping customer's HDD's!) he 'personally' got onto it.

    Quick help for you all:

    Before re-applying an update to try fix a fault, do a backup!

    Cheers,

    F
     

Share This Page