Mac Pro front USB ports not working?

iranintoavan

macrumors regular
Original poster
May 3, 2005
113
0
I just tried plugging my mouse into the ports in the front, and apparently they don't work. I am now using the ports on my keyboard, but I would like to figure it out. It's my first mac so if you have any suggestions let me know. Thanks in advance.
 

iranintoavan

macrumors regular
Original poster
May 3, 2005
113
0
Yeah, also tried an external hard drive, and it didn't mount until i plugged it into the keyboard hub.
 

Danksi

macrumors 68000
Oct 3, 2005
1,554
0
Nelson, BC. Canada
There could be a loose cable inside the box. Can you trace a cable from the front panel to the motherboard. Do ALL the ports not work?
 

iranintoavan

macrumors regular
Original poster
May 3, 2005
113
0
Danksi said:
There could be a loose cable inside the box. Can you trace a cable from the front panel to the motherboard. Do ALL the ports not work?
The headphone works, neither usb but thats all I could test. I will probably open up the case tomorrow and see what i can do. I have built many pc's before so I shouldn't have a problem. Just wanted to see if it might have been a common problem or anything.
 

Photothug

macrumors newbie
Apr 2, 2008
2
0
I have the same problem

Apple gave me a few things to try like unplugging everything which resets the power management and then also resetting PRAM, which fixed the problem for only a short time.

I have taken it to an authorized Apple repair, and they replaced the USB ports and the circuits. Got it back and it worked for a short time and then stopped working so APPLE told me to take it back to the authorized repair to get the logic board replaced.

I just plugged a CF Card reader and no power. The USB port will read nothing. No iPhone, no USB card reader, no USB drive, no nothing.

This is getting annoying. Can I request a new computer or something? this is ridiculous.
 

J@ffa

macrumors 6502a
Jul 21, 2002
662
38
Behind you!
This is getting annoying. Can I request a new computer or something? this is ridiculous.
They will probably replace it eventually. They'll maybe try new ports on the new logic board, and if that doesn't work, if the manager is particularly hard line they might go for one more logic board (unlikely, but it depends on how old the machine is, really). They will replace it eventually, they won't let it get ridiculous for their sake as much as yours.
 

blur35mm

macrumors member
Jan 18, 2007
50
0
Same Issue Here

I just had my logic board replaced as the ethernet ports stopped working and although the firewire ports work fine and the headphones jack works, the 2 front USB ports stopped working. This is an early 2008 Mac Pro 8core 2.8. A little disappointed that I had to have the logic board replaced already and now another issue with these 2 front ports.

My macs in the past have never had any problems...

At least it is under warranty...but still a pain in the behind.
 

mcvaughan

macrumors 6502a
Aug 9, 2007
765
215
Houston, TX
I just had my logic board replaced as the ethernet ports stopped working and although the firewire ports work fine and the headphones jack works, the 2 front USB ports stopped working. This is an early 2008 Mac Pro 8core 2.8. A little disappointed that I had to have the logic board replaced already and now another issue with these 2 front ports.

My macs in the past have never had any problems...

At least it is under warranty...but still a pain in the behind.
Yes, it is a pain. I just got my Mac Pro back after being at the Genius Bar for 2+ weeks. They replaced the logic board, the front board (presumably where the USB ports are) and the cable that connects the two. I hope I don't have any more issues as this sucker is too heavy to be hauling around.
 

blur35mm

macrumors member
Jan 18, 2007
50
0
Yes, it is a pain. I just got my Mac Pro back after being at the Genius Bar for 2+ weeks. They replaced the logic board, the front board (presumably where the USB ports are) and the cable that connects the two. I hope I don't have any more issues as this sucker is too heavy to be hauling around.
EXACTLY! But this make me realize I need the extended warranty because who knows what else will go wrong next year....that logic board was $945 to replace with labor.
 

HitchHykr

macrumors 6502a
Jun 13, 2007
542
1
Virginia
Now that you mentioned it I am having some problems with the front USB ports. I was using a USB memory stick and it would unmount by itself after a few minutes. I thought it was the $24.99 memstick and not my $2.5k MacPro! :(

BTW, the same USB memory stick works fine on a G5, I'll test some more on the MacPro.
 

blur35mm

macrumors member
Jan 18, 2007
50
0
Now that you mentioned it I am having some problems with the front USB ports. I was using a USB memory stick and it would unmount by itself after a few minutes. I thought it was the $24.99 memstick and not my $2.5k MacPro! :(

BTW, the same USB memory stick works fine on a G5, I'll test some more on the MacPro.
Yeah not sure what the deal is...worked fine before my logic board replacement. Will take it back to genius bar and if they need to replace something else, ask them to test every port before giving it back. Also just ordered the apple care for my mac pro. Who knows if this comes back to haunt me after its fixed 2 years from now. :)
 

blur35mm

macrumors member
Jan 18, 2007
50
0
Fixed!

Just to follow up, took my Mac Pro to the Genius Bar today. Was hoping it wasn't a problem with the new logic board they put in last week. Sure enough, Danksi (post above) was right. They forgot to hook up the USB wire to the new logic board (or it wasn't hooked up properly). Anyway, 10 minute wait and they had it working like a charm.

The guy said that since the other ports were working fine (firewire/headphones) and just USB dead that most of the time it means the wire is loose.

Hope this information helps.

BTW, gotta love the Genius Bar. That is why I pay the Apple premium because as long as you are following the rules, the customer service is top notch, some of the best I've ever seen.

Cheers-
Blur
 

Fogtripper

macrumors member
Apr 19, 2008
99
0
I have a lot of the same problems with my USB ports, both front and back (MP 3.0 early 08).

A quick search of the apple.com discussions (under support) shows that quite a few folks have issues like this with their MPs. Seems Apple is being slow to admit there is a widespread problem however, instead blaming all of the third party USB cords.

I honestly think the USB system on the MPs is horribly underpowered.
 

blur35mm

macrumors member
Jan 18, 2007
50
0
I have a lot of the same problems with my USB ports, both front and back (MP 3.0 early 08).

A quick search of the apple.com discussions (under support) shows that quite a few folks have issues like this with their MPs. Seems Apple is being slow to admit there is a widespread problem however, instead blaming all of the third party USB cords.

I honestly think the USB system on the MPs is horribly underpowered.
I would take it to the Genius Bar ASAP. If the rear ports are giving you problems, might be the logic board. If just the front, odds are it is a loose wire. Should be under warranty and a few days to fix.
 

inismor

macrumors newbie
Dec 6, 2008
3
2
Front ports aren't 2.0

It bears mentioning that the front ports on a Mac Pro are only 1.0 compliant. You can verify this by using System Profiler. It bugged me to no end that a lot of USB devices I tried to plug into the front ports just wouldn't work. Found out they *required* 2.0...

______________
update: This may be because the Apple Bluetooth module is plugged into the bus that includes the front ports and is only a 1.0 device. Or it may be a hardware problem on my part. I just always assumed it was just 1.0, but after reading some more...
 

Earl Urly

macrumors regular
Jul 11, 2004
221
1
No, all USB ports on the MacPro are 2.0.

All of the front ports and power switch are attached to the Front Panel Board. It's one discrete part that can easily be switched out and should be covered under AppleCare. There is one USB cable that runs from the FPB to the logic board, this is what they probably adjusted, tightened, or replaced.
 

todesto

macrumors member
Jan 5, 2015
90
7
Fullerton, CA
I know this is old thread but I use 5,1 and everything was working fine until I plugged in SATA reader to front USB and computer shut off. Once I rebooted, front USB stopped working. So I got the replacement but still same thing. power button, headphone, firewire works but no USB. What could cause this?
 

h9826790

macrumors G5
Apr 3, 2014
13,998
6,618
Hong Kong
I know this is old thread but I use 5,1 and everything was working fine until I plugged in SATA reader to front USB and computer shut off. Once I rebooted, front USB stopped working. So I got the replacement but still same thing. power button, headphone, firewire works but no USB. What could cause this?
Sounds like you burn the USB ports / board. Did you send it back to apple for fixing? Or the "replacement" is done by someone else? If the port still doesn't work after repair, obviously they didn't fix anything.
 

haralds

macrumors 65816
Jan 3, 2014
1,158
344
Silicon Valley, CA
I just tried plugging my mouse into the ports in the front, and apparently they don't work. I am now using the ports on my keyboard, but I would like to figure it out. It's my first mac so if you have any suggestions let me know. Thanks in advance.
The front ports do not support more than the standard USB 2 currents. USB ports will shut down in hardware until you power down, if they think there is too much draw.
A mouse should not trigger that. But you might try a device known not to draw much power like an externally powered hub or small flash stick.
 

todesto

macrumors member
Jan 5, 2015
90
7
Fullerton, CA
Sounds like you burn the USB ports / board. Did you send it back to apple for fixing? Or the "replacement" is done by someone else? If the port still doesn't work after repair, obviously they didn't fix anything.
I got front USB port module replaced myself.

so usb controller of the board must be burned....is there a fix for this?
 

h9826790

macrumors G5
Apr 3, 2014
13,998
6,618
Hong Kong
I got front USB port module replaced myself.

so usb controller of the board must be burned....is there a fix for this?
I think unless you really need the port at that exact location, otherwise, install a cheap USB 3.0 card is a much easier solution to get more USB ports (and the connection is 10x faster as well).

May be you still need some bootable USB port, but there are 3 at the back already.
 

tzer0

macrumors newbie
Oct 13, 2008
3
0
11/20/2018: SOLVED! I had the same problem. The posted Power Reset Fix only works on the Mac Book Pro laptops. For the tower you have to replace the battery behind the Graphics Card that keeps time for the clock when it's switch off. It's a disc type called a 2032. You can find them anywhere next to the watch batteries. A forum had this answer and it worked for me. I know that sounds strange, but it did the trick. For some reason that battery has something to do with running the USB ports



I just tried plugging my mouse into the ports in the front, and apparently they don't work. I am now using the ports on my keyboard, but I would like to figure it out. It's my first mac so if you have any suggestions let me know. Thanks in advance.
[doublepost=1542754932][/doublepost]You have to replace the battery behind the Graphics Card that runs the clock. I had the same problem. A forum had this answer and it worked for me. I know that sounds strange, but it did the trick.



I just tried plugging my mouse into the ports in the front, and apparently they don't work. I am now using the ports on my keyboard, but I would like to figure it out. It's my first mac so if you have any suggestions let me know. Thanks in advance.
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.