Mac Pro hangs, software or hardware issue? Help me troubleshoot please

Discussion in 'Mac Basics and Help' started by fougstedt, Jun 22, 2007.

  1. fougstedt macrumors newbie

    Joined:
    Jun 22, 2007
    #1
    Hi

    I bought a mac pro (2,66 dual core) with 1 gb ram and an x1900xt gfx card in november. It's been as sweet to me as only a mac can be up until recently when I added 1gb more third party ram to it, 2x512 Crucial sticks which I've read many good things about.

    Now it can occasionally do a kernel panic (i think thats what its called) and lock up with the gray 'you need to restart your computer' error. This usually happens when I play World of Warcraft, between 5 and 20 minutes after starting it up and regardless of what other programs I have running in the background. After I reboot I can usually play for hours and do other things after without it happening again though. Once so far it has locked up a second time as well however.

    This lockup has also happened several times while viewing video files with VLC however, and once or twice in other programs as well, so it's not a WoW-specific issue.

    Now what has me puzzled is if this really is bad ram or if its something else... Here's what I've done so far:
    * Run several complete runs of Memtest, booted in single user mode. It found no faults at all in any test.
    * Removed Apple RAM (2x512mb that came with the system) and run puter with only the new Crucial rams in it for several days. It didnt' lock up or display any problems or errors at all. This was with the two Crucial 512mb chips put into the same slots that the original Apple chips had.
    * Put the Apple RAM back in, in the slots that the Crucial RAM first had. With the full 2GB RAM (but with the chips in switched slots) the system once again locks up occasionally when playing WoW or video files.

    I have put the two new RAM chips in the first slots of the second card, as illustrated in the mac pro manual (and on the inside of the box). In the last step above I switched crucial and Apple positions but still keep the pairs together and only use the two innermost slots in the top and bottom card.

    If I use windows in bootcamp mode (XP with SP2) it has yet to display any errors or lock up at all (beyond what windoze normally does of course :) ). I only use XP to play games so there is a load on the gfx card and memory that should be somewhat similar to what WoW does to it in mac os, I think.

    Only other modification I have done is to replace the cooler on the x1900xt card with an Accelero X2, which I read many good reports of and which has worked perfectly for several months before I got the new RAM. In other words it could perhaps be a thermal issue but its unlikely since nothing has happened in windows gaming and since everything worked perfectly for a long time before the new RAM was purchased.

    Now I'm looking for suggestions to find what could be wrong.
    What further test can I do?
    Can it be a software issue that has crept into my system around the same time as the memory upgrade or is it hardware?
    Could it be a temperature issue, despite no indications of that and me living in cool, rainy Sweden? :)
    Could it be caused by the slots used on the memory cards? In other words, can I put the new chips in the two outmost slots on the top card instead (thereby not using the bottom card at all) and try that or will the memory not work properly then?

    This has me puzzled and I'd be very grateful for any tips you folks can give me on finding out what's actually wrong here :) Since the memory doesn't register any faults at all in testing and works on its own, I doubt I will be able to return it to the store...
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Remember that memory testing apps are pretty bad at finding dodgy memory. Having said that, it kinda sounds like you have a dodgy slot (or two) in the machine, so it's probably best to take it back to Apple. :eek:
     

Share This Page