Mac Pro Java Problems

Discussion in 'Mac Pro' started by Fischer71, Oct 3, 2013.

  1. Fischer71 macrumors newbie

    Joined:
    Oct 3, 2013
    #1
    I have a Mac Pro running Safari 6.0.5 and OS X 10.7.5. I have been trying for a couple of days to install Java 7. I downloaded latest version from the Java site and it will not install. I re-downloaded several times. No change. It goes through the install wizard and gets all the way to the end and says installation failed.

    Any help will be greatly appreciated.
     
  2. elvisizer macrumors 6502

    Joined:
    May 29, 2003
    Location:
    San Jose
    #2
    run the install, then open the Console application (//Applications/Utilities/Console) and check /var/log/install.log
    or, open up terminal and type in cat /var/log/install.log
    find the entries from the java install attempt, and post 'em here.
     
  3. Fischer71 thread starter macrumors newbie

    Joined:
    Oct 3, 2013
    #3
    Mac Pro Java Problems

    Elvisizer -- here is the info from the log file:


    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: @(#)PROGRAM:Install PROJECT:Install-690
    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: @(#)PROGRAM:Installer PROJECT:Installer-538
    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: Hardware: MacBookPro5,1 @ 2.40 GHz (x 2), 4096 MB RAM
    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: Running OS Build: Mac OS X 10.7.5 (11G63)
    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: Env: PATH=/usr/bin:/bin:/usr/sbin:/sbin
    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: Env: TMPDIR=/var/folders/zx/smywtmmd07l_gvvc0gpss5tr0000gp/T/
    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: Env: SHELL=/bin/bash
    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: Env: HOME=/Users/Dan
    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: Env: USER=Dan
    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: Env: LOGNAME=Dan
    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: Env: DISPLAY=/tmp/launch-OGaL7C/org.x:0
    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: Env: SSH_AUTH_SOCK=/tmp/launch-JUUlPp/Listeners
    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: Env: Apple_Ubiquity_Message=/tmp/launch-D2lm6i/Apple_Ubiquity_Message
    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: Env: Apple_PubSub_Socket_Render=/tmp/launch-UFgA8v/Render
    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: Env: COMMAND_MODE=unix2003
    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: Env: __CF_USER_TEXT_ENCODING=0x1F6:0:0
    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: Java 7 Update 40 Installation Log
    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: Opened from: /Volumes/Java 7 Update 40/Java 7 Update 40.pkg
    Oct 4 09:52:23 Mac-Pro-1 Installer[1164]: Product archive /Volumes/Java 7 Update 40/Java 7 Update 40.pkg trustLevel=202
    Oct 4 09:52:32 Mac-Pro-1 Installer[1164]: InstallerStatusNotifications plugin loaded
    Oct 4 09:52:37 Mac-Pro-1 runner[1168]: Administrator authorization granted.
    Oct 4 09:52:37 Mac-Pro-1 Installer[1164]: ================================================================================
    Oct 4 09:52:37 Mac-Pro-1 Installer[1164]: User picked Standard Install
    Oct 4 09:52:37 Mac-Pro-1 Installer[1164]: Choices selected for installation:
    Oct 4 09:52:37 Mac-Pro-1 Installer[1164]: Install: "Java 7 Update 40"
    Oct 4 09:52:37 Mac-Pro-1 Installer[1164]: Install: "JavaAppletPlugin"
    Oct 4 09:52:37 Mac-Pro-1 Installer[1164]: Java 7 Update 40.pkg#javaappletplugin.pkg : com.oracle.jre : 1.0
    Oct 4 09:52:37 Mac-Pro-1 Installer[1164]: ================================================================================
    Oct 4 09:52:37 Mac-Pro-1 Installer[1164]: It took 0.00 seconds to summarize the package selections.
    Oct 4 09:52:37 Mac-Pro-1 Installer[1164]: -[IFDInstallController(Private) _buildInstallPlan]: location = file://localhost
    Oct 4 09:52:37 Mac-Pro-1 Installer[1164]: -[IFDInstallController(Private) _buildInstallPlan]: file://localhost/Volumes/Java%207%20Update%2040/Java%207%20Update%2040.pkg#javaappletplugin.pkg
    Oct 4 09:52:37 Mac-Pro-1 Installer[1164]: Set authorization level to root for session
    Oct 4 09:52:37 Mac-Pro-1 Installer[1164]: Will use PK session
    Oct 4 09:52:38 Mac-Pro-1 Installer[1164]: Starting installation:
    Oct 4 09:52:38 Mac-Pro-1 Installer[1164]: Configuring volume "Macintosh HD"
    Oct 4 09:52:38 Mac-Pro-1 Installer[1164]: Preparing disk for local booted install.
    Oct 4 09:52:38 Mac-Pro-1 Installer[1164]: Free space on "Macintosh HD": 202.57 GB (202566717440 bytes).
    Oct 4 09:52:38 Mac-Pro-1 Installer[1164]: Create temporary directory "/var/folders/zx/smywtmmd07l_gvvc0gpss5tr0000gp/T//Install.1164gVxMb7"
    Oct 4 09:52:38 Mac-Pro-1 Installer[1164]: IFPKInstallElement (1 packages)
    Oct 4 09:52:38 Mac-Pro-1 Installer[1164]: Using authorization level of root for IFPKInstallElement
    Oct 4 09:52:40 Mac-Pro-1 installd[1171]: PackageKit: ----- Begin install -----
    Oct 4 09:52:40 Mac-Pro-1 installd[1171]: PackageKit: request=PKInstallRequest <1 packages, destination=/>
    Oct 4 09:52:40 Mac-Pro-1 installd[1171]: PackageKit: packages=(
    "PKLeopardPackage <file://localhost/Volumes/Java%207%20Update%2040/Java%207%20Update%2040.pkg#javaappletplugin.pkg>"
    )
    Oct 4 09:52:40 Mac-Pro-1 installd[1171]: PackageKit: Will do receipt-based obsoleting for package identifier com.oracle.jre (prefix path=Library/Internet Plug-Ins/JavaAppletPlugin.plugin)
    Oct 4 09:52:40 Mac-Pro-1 installd[1171]: PackageKit: Extracting file://localhost/Volumes/Java%207%20Update%2040/Java%207%20Update%2040.pkg#javaappletplugin.pkg (destination=/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/Cleanup At Startup/PKInstallSandbox-tmp/Root/Library/Internet Plug-Ins/JavaAppletPlugin.plugin, uid=0)
    Oct 4 09:52:47 Mac-Pro-1 installd[1171]: PackageKit: component Library/Internet Plug-Ins/JavaAppletPlugin.plugin/.Contents/Resources/Java Updater.app missing or previously relocated
    Oct 4 09:52:47 Mac-Pro-1 installd[1171]: PackageKit: Executing script "./preinstall" in /private/tmp/PKInstallSandbox.SYnnPy/Scripts/com.oracle.jre.Ccf8Yf
    Oct 4 09:52:47 Mac-Pro-1 installd[1171]: PackageKit: Shoving /var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/Cleanup At Startup/PKInstallSandbox-tmp/Root (1 items) to /
    Oct 4 09:52:54 Mac-Pro-1 installd[1171]: PackageKit: Executing script "./postinstall" in /private/tmp/PKInstallSandbox.SYnnPy/Scripts/com.oracle.jre.Ccf8Yf
    Oct 4 09:52:55 Mac-Pro-1 installd[1171]: ./postinstall: com.oracle.java.Java-Updater: Already loaded
    Oct 4 09:52:55 Mac-Pro-1 installd[1171]: ./postinstall: com.oracle.java.Helper-Tool: Already loaded
    Oct 4 09:52:57 Mac-Pro-1 installd[1171]: ./postinstall: java.lang.IllegalArgumentException: Invalid argument CFG_FILE: /Library/Application Support/Oracle/Java/java.settings.cfg
    Oct 4 09:52:57 Mac-Pro-1 installd[1171]: ./postinstall: at com.oracle.install.InstallOptions.validateConfigFile(InstallOptions.java:163)
    Oct 4 09:52:57 Mac-Pro-1 installd[1171]: ./postinstall: at com.oracle.install.InstallOptions.parseArguments(InstallOptions.java:99)
    Oct 4 09:52:57 Mac-Pro-1 installd[1171]: ./postinstall: at com.oracle.install.InstallOptions.main(InstallOptions.java:43)
    Oct 4 09:52:58 Mac-Pro-1 installd[1171]: ./postinstall: LSGetApplicationForInfo() failed with error -10814 while trying to determine the application with bundle identifier com.google.chrome.
    Oct 4 09:52:58 Mac-Pro-1 installd[1171]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “Java 7 Update 40.pkg”." UserInfo=0x7fe5abc7cc80 {NSFilePath=./postinstall, NSURL=file://localhost/Volumes/Java%207%20Update%2040/Java%207%20Update%2040.pkg#javaappletplugin.pkg, PKInstallPackageIdentifier=com.oracle.jre, NSLocalizedDescription=An error occurred while running scripts from the package “Java 7 Update 40.pkg”.} {
    NSFilePath = "./postinstall";
    NSLocalizedDescription = "An error occurred while running scripts from the package \U201cJava 7 Update 40.pkg\U201d.";
    NSURL = "file://localhost/Volumes/Java%207%20Update%2040/Java%207%20Update%2040.pkg#javaappletplugin.pkg";
    PKInstallPackageIdentifier = "com.oracle.jre";
    }
    Oct 4 09:52:58 Mac-Pro-1 Installer[1164]: install:didFailWithError:Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “Java 7 Update 40.pkg”." UserInfo=0x7f96d2c5dd10 {NSFilePath=./postinstall, NSURL=file://localhost/Volumes/Java%207%20Update%2040/Java%207%20Update%2040.pkg#javaappletplugin.pkg, PKInstallPackageIdentifier=com.oracle.jre, NSLocalizedDescription=An error occurred while running scripts from the package “Java 7 Update 40.pkg”.}
    Oct 4 09:52:59 Mac-Pro-1 Installer[1164]: Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.
    Oct 4 09:52:59 Mac-Pro-1 Installer[1164]: IFDInstallController D1473E40 state = 7
    Oct 4 09:52:59 Mac-Pro-1 Installer[1164]: Displaying 'Install Failed' UI.
    Oct 4 09:52:59 Mac-Pro-1 Installer[1164]: 'Install Failed' UI displayed message:'The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.'.

    This is all above my pay grade! Many many thanks for your help
     
  4. elvisizer, Oct 4, 2013
    Last edited: Oct 4, 2013

    elvisizer macrumors 6502

    Joined:
    May 29, 2003
    Location:
    San Jose
    #4
    here's the problem:
    something's funky with launch service's information for your installation of chrome.
    try using this command to rebuild your launch service database, then run the java installation again. if that doesn't work, uninstall and reinstall chrome after rebuilding the launch service db, then run the java installation again.
    Note- the command i linked to is 10.8 specific. If you're not on 10.8, let me know what rev of OS X you are running and I'll get you the right one.
     
  5. Fischer71 thread starter macrumors newbie

    Joined:
    Oct 3, 2013
    #5
    Mac Pro Java Problems

    Elvisizer,

    I reallly appreciate your great help! First, I am running 10.7.5. But beyond that, I do not have Chrome loaded on the computer! I did have some months ago because it automatically loaded with something else I had loaded. I didn't even know it was there for a couple of weeks and then I found it and uninstalled it. I run Safari 6.0.5

    Hope that info helps. Many thanks.
     
  6. elvisizer macrumors 6502

    Joined:
    May 29, 2003
    Location:
    San Jose
    #6
    yeah, rebuilding the LS database should definitely fix it then.
    I'm not finding the path for the command on lion anywhere online, and I don't have anything running 10.7 anymore so you can either run this command, which will find the lsregister program, then execute it:
    Code:
    `sudo find /System/Library/Frameworks -name lsregister` -kill -seed
    or download onyx and use it to rebuild the launchservices database. it's under maintenance > rebuild > launchservices in onyx.
     
  7. Fischer71 thread starter macrumors newbie

    Joined:
    Oct 3, 2013
    #7
    Mac Pro Java Problems

    Elvisizer,

    I'm going to have to put you on the payroll! The sudo command would not work, so I downloaded Onyx and ran it. It showed my start volume to be needing a repair. It gave instructions to use the Command - R at start up which I did. Then using the disk utility I ran verification and it showed all ok. I ran repair and it showed all ok.

    Re ran Onyx and got the same message again that disk needed repair. So I went through all of it a second time. Same results.

    ???

    Thanks much.
     
  8. elvisizer macrumors 6502

    Joined:
    May 29, 2003
    Location:
    San Jose
    #8
    I wouldn't worry about the disk repair right now- have onyx skip it's disk check so you can rebuild launch services.
    Once that's done, then check the disk repair errors to see if you need to replace your drive. Were they SMART errors?
     
  9. Fischer71 thread starter macrumors newbie

    Joined:
    Oct 3, 2013
    #9
    No, they were not SMART errors. It went through that check just fine. I will go ahead with Onyx and see if that works. Thanks.
     
  10. Fischer71 thread starter macrumors newbie

    Joined:
    Oct 3, 2013
    #10
    Elvisizer,

    MANY thanks for all your help. I got Java loaded successfully. I cannot tell you how much I appreciate your taking the time and making the effort to help me.

    Dan
     
  11. elvisizer macrumors 6502

    Joined:
    May 29, 2003
    Location:
    San Jose
  12. Steven6702 macrumors newbie

    Joined:
    Oct 16, 2013
    #12
    Hi Elvisizer,

    I am having this same problem on 10.8.3. I ran the command you cited to rebuild the LS database (thank you!) and did not get an error. However, the install is still failing. My install log is nearly identical to the above with the error 10814, but it is Firefox instead of Chrome.

    Do you have any ideas on where to look next? We've tried reaching out to corporate IT as well as Java but as expected neither was able to help with this specific of an issue.

    Thank you!

    Steven
     
  13. elvisizer macrumors 6502

    Joined:
    May 29, 2003
    Location:
    San Jose
    #13
    hey steven, sorry it took awhile, been a busy week for me and haven't been to the site... in fact, I was out of town last week for jnuc, so i guess it's been two weeks!

    did you download onyx and use it to rebuild launchservices as well?
    if you haven't, do that.
    if you did and that didn't work, can you post your log?
     

Share This Page