Mac Pro Leopard Bootcamp 'issues'

Discussion in 'macOS' started by iZac, Oct 28, 2007.

  1. iZac macrumors 68000

    iZac

    Joined:
    Apr 28, 2003
    Location:
    Shanghai
    #1
    Is anyone else having bootcamp issues with Mac Pros using Leopard? If so, 'halp!' if not, heres my explanation of the problem and hopeful resolution will follow from you kind chaps:

    I set up a partition using Bootcamp ready to put XP on it (i NEED a bootcamp partition, since Studio Max wont cut the mustard using Parallels) . I put my XP disk in, restart, it dumps all the relevant files onto the Windows partition, and restarts ready for that low res install process. The trouble is, at the point where is says "press any key to boot from CD. . . " in command line, i wait for it to boot up from the hard disk and it says "disk error" and "press any key_" the keyboard doesnt respond and i have to power off from the button. Rinse and repeat.

    Ive tried this twice and created two Fat32 partitions from disk utility and from boot camp. This exact process worked fine under Tiger, could it really be my install disk at fault, or is it Leopard playing silly buggers?
     
  2. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    this is all i can think of... have you tried holding option on startup and selecting the windows partition? is seems like its trying to boot from the cd again.
     
  3. outz macrumors 6502

    Joined:
    Jul 17, 2007
    #3
    I had this problem as well - After it boots off the WinXP cd for setup, it will ask you to select the partition etc. be sure to tell the Windows installer to format the partition as FAT, and it will say something like 'partition is over 2048MB will use FAT32' this should resolve your problem... it looks like disk utility is partitioning it and marking it as fat32, but not actually formatting it correctly or whatever.
     
  4. iZac thread starter macrumors 68000

    iZac

    Joined:
    Apr 28, 2003
    Location:
    Shanghai
    #4
    Yeah i tried that, to no joy unfortunately. Thanks anyway!


    I'll have a go at this as well, Outz, but not now, its bed time over here. Ill report back tomorrow after ive tried it, thanks!
     
  5. bass309 macrumors newbie

    Joined:
    Oct 28, 2007
    #5
    MacBook Pro Leopard Boot Camp 'issues'

    I have also experienced problems with the new version of Boot Camp with Leopard...
    I have a MacBook Pro 2.33ghz, 2gb ram and have especially purchased and previously installed a "Generic FULL OEM" version of XP w/SP2 on Tiger 1.4.10 using Boot Camp Beta's from 1.2 to 1.4 (to update drivers)
    I decided to make the upgrade to Leopard, so, to prepare for this I backed up my files, formatted my drive to avoid any conflicts and also just for a general clean up. Now I did actually create 2 partitions using "Terminal" and a Boot Camp Beta previously (FAT32 for sharing and NTFS for security)
    This time I decided not to have the the NTFS partition and install directly from Boot Camp 2.0 onto a FAT32 partition. I created the partition without any problems and Windows setup continues until it reaches the point where it asks you "Which partition you would like to install?" Now it only gives me 3 options:
    1) I can quit the windows setup
    2) I can delete a partition
    3) I can install Windows
    At NO stage does it give me the option to re-format a partition as required by Apple's Boot Camp Setup Instructions. I opted for the obvious, install windows on (BOOTCAMP) FAT32 and it continues with Windows setup until it re-boots. Then I get "To boot from disc press any key option" which I decided not to do the first time and then I get the "DISK ERROR" message. So thinking that XP still needed to boot from the CD ROM I chose that..... It starts Windows setup continues up to the same 3 options I was given before...So I choose the (BOOTCAMP) FAT32 partition and it continues until re-boot (sounds familiar, huh?) I booted into OS X and looking at the contents of the "BOOTCAMP" partition it has installed a file called Windows and another copy labeled Windows.0.:confused:
    After going round in circles trying the "Delete Partition" option (I know I wasn't supposed to but thought I would give it a try) and formatting, checking the drive for problems, taking off the Open Firmware Password and zapping the PRAM, I am running out of ideas. Now after doing some research there seems to be conflicting theories as to wether you can use the "Generic FULL OEM" version of XP w/SP2..... BUT I had no problems with this before with earlier installs.... why now? I have also found out that even if I wanted to downgrade to Tiger and install using the Boot Camp Beta 1.4 I still have, I would eventually run into problems.
    After visiting the Apple Store in Regent Street a number of times with questions previously, not related, I have never been able to find answers and I have the feeling that they are going to have as much of an idea as I have due to the recent release of Leopard, or they are going to tell me that it is a Windows install problem and that I need to contact Microsoft! These people NEED to know more about the products they are selling instead of just selling....!:mad:
    Now don't get me wrong I LOVE my MacBook Pro but I am getting desperate as I need XP Pro to study and am starting to wonder if I was better off keeping my older PowerBook and purchasing a cheap laptop with XP Pro already installed. It may have been less problematic and a lot cheaper. Any help in this situation would be appreciated ...........Thanks.

    OK.... I have finally managed to format the drive and even have the choices with the type of partition. I gave the partition back to OS X that I had created with Boot Camp repaired permissions using the install disk and tried again.... This time SUCCESS..........
    But..............
    I am now joining the many others that are receiving the "Missing hal.dll file" :mad:
    I have tried reinstalling again and trying different options for the type of partition both FAT32 and NTFS......
    So I thought I would try and use an external drive to install Tiger and Boot Camp 1.4 beta. So I went to resize my partition with Leopard and am now getting "Partition failed Filesystem resize support required such as HFS+ with Journaling enabled." I have looked at the info for the drive and IT IS Mac OS Extended (Journaled)!
    AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAARGH!


    Peace, Love, Unity, Respect & GREAT Music!:)
     
  6. richorlin macrumors regular

    Joined:
    Sep 19, 2007
    #6
    Mac Pro Leopard Bootcamp 'issues'

    This is a known issue with Boot Camp under Leopard.

    Apple issued a support document but it doesn't seem to work.
    I think we'll all have to wait for a bug-fix or boot from an external Tiger drive that has Boot Camp already installed. Bummer!
     
  7. vwgtiturbo macrumors newbie

    Joined:
    Feb 27, 2007
    #7
    Ditto...

    I am having this same issue. HOWEVER, I did get it to work ONCE. After bootcamp sets up the partition and boots from the XP disc, I told it to format the bootcamp partition as NTFS, and the install worked. I realized later that I wouldn't be able to write to the partition is OS X (come on, Linux can write NTFS, why not OS X?), so I redid the install, this time as FAT, and now it won't work. So, maybe if you try it as NTFS, it will work for you.
     
  8. Hobofuzz macrumors regular

    Joined:
    Oct 9, 2006
    #8
    I've gotten the disk error issue once, and it was because I had modified the partition bootcamp makes. That partition MUST be exactly where bootcamp puts it.

    I'm guessing the Windows installer changes the MBR in the protective header of the GPT, but this doesn't cause the actual GPT to reflect the changes made to the MBR. If the MBR and the two GPT entries at the beginning and end of the disk don't match, you'll run into really weird issues.

    Like, for example, I have one external hard drive partition formatted as both a FAT32 and HFS+ partition. Mac OS X reads the GPT entry for the partition, listing it as an HFS+ partition, and can only see the files put there from within Mac OS X, yet info still shows the space is being occupied by the windows files. In Windows, the MBR is read, and displays the partition as FAT32, and only the Fat32 files are seen, yet the space taken by the HFS+ files is reflected by info. The partition works just fine, and I have yet to have any problems. Hell, I even reformatted that partition the other day, and Windows STILL sees the FAT32 files. They're perfectly in-tact. It's really weird, but it's pretty cool too.
     
  9. iZac thread starter macrumors 68000

    iZac

    Joined:
    Apr 28, 2003
    Location:
    Shanghai
    #9
    I'm glad to see im not the only one ... well im not glad, i wish no one had to go through these issues! I deleted my windows partition under XPs boot CD and reinstalled it as fat32, and now i get the "missing hal.dll" issue that other people have had.

    I guess we'll have to wait it out for an apple posted solution, since this seems to be such a widespread issue.
     
  10. outz macrumors 6502

    Joined:
    Jul 17, 2007
    #10
    Did you try what I posted above? (not deleting the partition via xp, simply formatting it with xp as fat)
     
  11. mstrswrd06 macrumors newbie

    Joined:
    Oct 30, 2007
    #11
    Fix!!

    I'm gonna try to post this everywhere I can. I found a fix to the Leopard Boot Camp "Disk Error" problem. This will enable Leopard users to install Windows XP onto an Intel based Mac before Apple releases the fix for Boot Camp that causes the "Disk Error" problem.

    Since the Windows Setup didn't ask how you wanted the partitioned formatted (What caused the problem), I thought that it'd be possible to do it manually before starting the setup.

    Here's what I did:

    When I first partitioned the drive with Boot Camp Assistant, I did it to 32 GB (This may be a preference, so try it out). After restarting and entering the Windows Setup, I went into the recovery console (Press R at the first setup screen, unless you're using a streamlined disc which may or may not have these options at the start; To put it simply, you'll need a disc with the recovery console on it, an official Windows XP cd will do the job).

    IMPORTANT: Use the diskpart command BEFORE formatting to confirm that your Boot Camp partition is the C: drive!!

    Once in the recovery console, and checking your partitions with diskpart, type the following to format your Boot Camp partition:

    format C: /Q /fs:ntfs

    It will confirm that you want to format.This will format the partition created by the Boot Camp Assistant into NTFS. The '/Q' flag indicated a quick format. This can be removed if you wish.

    After doing this, type exit to restart. Continue the Windows Setup as usual.

    No disk error, no corrupt/missing hal.dll, no problems. Feel free to email if there are problems.
     
  12. cauravou macrumors newbie

    Joined:
    Oct 31, 2007
    #12
    Still missing hal.dll

    I had the same problem, was not able to access the Recovery Console through holding down "R".

    So when Windows Setup started and I came to the screen asking me to confirm which partition I wanted Windows installed on, I tried deleting the 32Gb partition labeled FAT and then it let me create a new partition in the same space.

    When it did that it gave me the option to use NTFS instead of FAT so I chose that option. It seemed to work, but... then when it tried to start Windows I got the message saying Windows could not start because of the missing hal.dll file. Any solution here? Thanks.
     
  13. mstrswrd06 macrumors newbie

    Joined:
    Oct 30, 2007
    #13
    Clarification: You don't hold down R as the setup initializes. When it first prompts you to begin setup, enter recovery console or exit, that's when you push R.

    At this screen:
    [​IMG]
    Press R
     
  14. enklined macrumors 6502

    Joined:
    Sep 13, 2007
    Location:
    Sacramento
    #14
    I'm getting the Disk Error after my format/install of Leopard, now.

    Originally I just upgraded, and my 1.4 Beta Boot Camp was fine (upgraded to 2.0).

    Now, I'm getting the Disk Error when trying to install from the same windows CD I did with 1.4 beta! What the hell...

    My CD doesn't offer the option of recovery, either. I guess I now have to try and get my hands on one that does? What the hell did apple change to make this not work now...this sucks!
     
  15. mstrswrd06 macrumors newbie

    Joined:
    Oct 30, 2007
    #15
    It does suck. I was real frustrated when it wouldn't work for me after the beta.

    Boot Camp 2.0 formats the new partition differently than the beta did. With the beta, it left it as an unformatted partition (Someone correct me if I'm wrong). So during Windows Setup, it had the option to format the new partition, which put the correct entries into the partition table. Boot Camp 2.0 formats the new Windows partition, so Windows Setup thinks it's a perfectly good partition to install on, and therefore doesn't offer formatting options. But it doesn't put new entires in the partition table, and that's why the disk error comes up when you start the second go-round of the installation.

    Did my fix work for anybody?
     
  16. vermeer macrumors newbie

    Joined:
    Nov 18, 2007
    #16
    Hey mstrswrd06,

    Your instructions worked fine for me: MBP C2d w/leopard 10.5.1.

    Now I can run hideous looking wXp alongside leop!

    Thanks so much for figuring out a fix.
     
  17. liquidthunder macrumors newbie

    Joined:
    Dec 1, 2006
    #17
    It works!

    Man ole' man, am I glad you posted this work around. I have been gouging my eyes out the past two days re-installing win xp. I had all of the problems everyone else had. I tries this solution out tonight, and finally! I can rest easy! I am installing splinter cell double agent right now as i type.

    This is the easiest and best solution and suggest everyone else having installation issues to give this a try.:D
     
  18. PokerOtaku macrumors newbie

    Joined:
    Dec 3, 2007
    #18
    paritions, boot camp, hal.dll and disk error nightmare

    first - I know many folks have been having issues with bootcamp and windows XP and there are probably several issues that are really taking place but I wanted to share my experience so that possibly it may help someone else...sorry for the long post.
    I recently purchased a MBP to take advantage of the dual boot option as I have many clients on a windows platform (poor people). I created two partitions using the diskutil command so that I can keep a FAT32 partition to use via both OS's for documents (I use cygwin on the Windows side and was going to just create a symbolic link to the *shared* partition so I can read/write docs in either OS)... this was my plan. I created my three partitions like so...
    diskutil resizeVolume disk0s2 83G "MS-DOS FAT32" "Docs" 40G "MS-DOS FAT32" "Windows" 25G
    (I know most already are aware but Boot Camp will only create one partition - so using Boot Camp was not an option for me)
    the command worked great - no issues and I proceeded to install Vista on the Windows partition...
    The Vista install went great, no problems at all then I decided to install some programs I need on the Windows side - this is where my nightmare begins... Vista is not compatible with most of the programs I need to use (Visual Studio and SQL Server issues) and I spent a long time trying to deal with that so I decided to install XP, which I know has no known issues, on the Windows partition...
    Install was going fine - I DO see the format screen (unlike some) and when the system creates all the installation files etc and reboots I get the following error
    "DISK ERROR PRESS ANY KEY TO RESTART"
    we all are familiar with this one - and of course there are no keys that work -
    hard shutdown and reboot -
    This was going on for some time - read forums, call friends, try this, try that - and nothing was working. I am a DB guy so forgive me, I am not an app or OS guy... but it seemed to me by what I was reading and hearing from folks is that the XP boot files are looking at a specific place to boot the OS - once I realized that I decided to change the order of my created partitions (and I guess they suggest NOT having the Windows data partition right after the mac one - ok, not sure why but..) and I did the install with the windows partition now as the 3rd partition. This worked great, installed fine but once I rebooted I had the following error
    "Missing Hal.dll file" or something like that -
    I was just bugged by this too - lots of searching, calling and pulling my hair out and then I decided to try a third attempt
    Using Boot Camp to create a partition and then installing XP then going back and partitioning the mac partition to create a FAT32 shared partition. Well, the install went great but then when I created the extra partition the XP OS was not bootable - this pointed me in the direction of what would fix my issue... and yes, I said fix because I now have Leopard, XP and a shared FAT32 partition on my machine and this is what I did (obviously, this was my specific issue but maybe it will help)
    I used Boot Camp to install XP then while on XP I edited the boot.ini file
    Right click computer -> Properties -> Advanced -> settings (under Startup and Recovery) -> clicked EDIT under System startup and then you will see your boot.ini file in notepad...
    you change the partition number to correspond to the partition location you are creating (mac will place the newly created partition last so on my machine the partition(#) is partition(4) ).
    I then rebooted into mac, partitioned the mac partition creating a new FAT32 partition like so -
    diskutil resizeVolume disk0s2 82G "MS-DOS FAT32" 40G
    (you should run diskutil list to see Your disk info) and Voila - done
    it now works... again, this worked for me and is how I did it - there are probably ways to deal with the boot files differently (I know you can probably deal with this by using recovery console) and this does create a windows partition with XP right after the mac one - something *they* say is not recommended.. not sure why but if anyone knows please respond.
    I think that covers it - oh, if you see a boot menu after you boot into windows, you failed to edit both partition location lines in your boot.ini file - you just need to make sure both the default and the operating system entries are the same partition number.

    Cheers - HTH
     

Share This Page