Mac Pro loses ability to sleep?

Discussion in 'Mac Pro' started by Ravich, Sep 20, 2014.

  1. Ravich macrumors 6502a

    Joined:
    Oct 20, 2009
    Location:
    Portland, OR
    #1
    Sometimes my mac pro is unable to successfully sleep. (2009 model)


    Normal behavior is that if no flagged programs are open, I it will automatically sleep after a period of inactivity. I can hear the "click" of my map pro and the fans (and hard drives) powering down when it does this. The light above the power button will slowly fade off and on while it is asleep (as opposed to the solid unwavering light when it is on normally). Of course, I can do this manually if I want via the apple menu.


    However, lately it wont do this. It will stay powered on indefinitely unless I tell it to manually, which still doesnt really work. It causes my monitor to stop displaying anything as though it were sleeping normally, however the computer is clearly still on: light above power button is still on, fans dont power down, no click, response right away when I shake the mouse.


    Usually this seems to happen when I have logic open for an extended period of time (this is a program that is flagged to not allow the computer to sleep while it is open), and then close logic. Even though the program is no longer open, and no other programs that would cause anything of the sort are open, it simply wont sleep until I shut it down.


    When I boot it up again, it usually performs normally, but now it simply wont sleep regardless of whether anything is open. No applications open and it still wont sleep.


    What is wrong with it?


    Edit: okay, I might slightly wrong. While I have found that when it starts doing this, it can be left alone for hours without ever entering sleep automatically, but I just tested it manually again, and using a timer, I have determined that it does, in fact, go to sleep, but only after a solid 22 or so seconds of waiting. It normally happens within 2-3 seconds.

    Any ideas?
     
  2. Cubemmal macrumors 6502a

    Joined:
    Jun 13, 2013
    #2
    The ways of Apple sleep are mysterious.

    Seriously, Apple - for inscrutable reasons of their own - try to make the sleep process far more difficult than it needs to be. Microsoft makes it simple, when you say sleep, that means you are leaving the computer, so you want it to sleep goddamit. It goes to sleep. Same for shutdown. If anything it's almost a little too aggressive, but I don't mind.

    Apple tries to be smart and graceful, which is stupid. It's stupid because they can't do that, and since they are also obsessed with power usage you frequently get the situation where the computer remains on for long periods of time. I really wish they just did the Microsoft solution and stopped trying to be smarter than they can be.

    In this case I've found that most often having open network connections from external machines causes trouble. I've seen it repeatably do a thing where if you connect from another computer, then put that one to sleep, the computer connected to doesn't get the message and will hang forever in case that other computer comes back on the connection. For this reason I shut off file sharing on all my computers - too troublesome. I just use SSH/SCP if I need that.

    That's the main one I know of that will cause issues, but there are many others.
     
  3. Ravich, Sep 21, 2014
    Last edited: Sep 21, 2014

    Ravich thread starter macrumors 6502a

    Joined:
    Oct 20, 2009
    Location:
    Portland, OR
    #3
    Could drop box do something like that?

    I'd also like to mention that a couple of times recently I've had 2 specific USB ports (one on the front and one on the back) stop functioning. Most of the time they work.



    Currently I am actually trying and failing to wake my Mac Pro from sleep. Keys and mouse dont do anything. I just tried switching USB ports and that didnt help.


    Pushing the power button doesnt do anything either. The light is slowly pulsing off and on, meaning it is asleep...


    This is all quite disturbing, frankly.



    edit: https://discussions.apple.com/thread/5157279?start=0&tstart=0

    Faulty power supply?


    edit2: http://forums.macrumors.com/showthread.php?t=1423968

    Now that I listen closely, fans are on, and warm air comes out of the back.



    Just in case, I removed all hard drives (internal spinning, PCIe SSDs, the SSD in below my DVD drive) and swapped out all my memory except for the OWC sticks, then tried again with only 2 sticks that came with the Mac Pro. Same problem.

    I guess that leaves a few possibilities: my boot drive, video card, and power supply. Assuming that it isnt something worse. I've been testing this the apple/apple sign in, so I think that rules out the possibility that it is anything software related. Is it possible that my UPS could be causing problems such as this?
     
  4. AppleDroid macrumors 6502a

    Joined:
    Apr 10, 2011
    Location:
    Illinois
    #4
    I'm having almost the same issue with my 2009 4c MP. For the last two weeks, not sure if it's after the latest iTunes and OSX updates, my computer won't wake from sleep. I've tried everything from resetting SMC/PRAM, unplugging all peripherals and even uninstalling drivers without luck.

    If it sleeps for more than 15 minutes I have to do a hard reset in order to get the machine to power up.
     
  5. Ravich, Sep 22, 2014
    Last edited: Sep 22, 2014

    Ravich thread starter macrumors 6502a

    Joined:
    Oct 20, 2009
    Location:
    Portland, OR
    #5
    Hm. I have read about MP users having this problem with early versions of mountain lion... For what it's worth, my MP hasnt had trouble waking up over the last 2 days or so.

    edit: Although earlier it did something that it has never done before: refused to open logic pro. Icon would just bounce in the dock indefinitely.
     
  6. Ravich thread starter macrumors 6502a

    Joined:
    Oct 20, 2009
    Location:
    Portland, OR
    #6
    Over the last couple of days, it has done the thing twice where it refuses to open any application (icon bounces on the doc indefinitely). One of the times there was a weird twist where it gave me the indefinite beach ball on chrome, wouldnt open any other applications, but if I force quit and reopened chrome, it would open and then immediately spin the beach ball indefinitely.

    And just now, 2 minutes ago, it put itself to sleep without any prompting. Hasnt done that in weeks.


    The hell is going on here?
     
  7. tomvos macrumors 6502

    tomvos

    Joined:
    Jul 7, 2005
    Location:
    In the Nexus.
    #7
    Have a look at this thread at Apple Discussions. There’s a know issue related to the iSight Firewire.

    Perhaps your MP is affected from the same bug (not necessarily to be caused only by the iSight FW).
     

Share This Page