Mac Pro not recognizing GPU and only booting from internal disks

Discussion in 'Mac Pro' started by anendlessches, Dec 11, 2015.

  1. anendlessches macrumors newbie

    Joined:
    Dec 11, 2015
    Location:
    Norway
    #1
    Hello all. I have been looking through quite a few posts on this forum regarding many of the ideas I have about upgrading my Mac Pro 1,1 and mac-related troubles I've been through, and it has been a great resource!

    And now I have this problem that I have tried googling for many times without finding anything, so I am hoping some of you might be able to save my day.

    A little while ago I bought a Mac Pro 1,1, used of course. I obviously got the seller to show me that it worked beforehand, and it seemed to work fine, but it needed some upgrades before I'd be completely satisfied (new GPU, X5365's, more RAM, SSD plus a few 7200RPM drives, etc.) and I am working on saving up for the rest of this, but I have bought a GPU already. I bought a used HIS Radeon HD 4870 and thought I'd just flash that to use in my Mac Pro. Seemed like a good idea and nothing to difficult. I'm not gonna go into detail about everything, but here comes my problem:

    I tried creating a FreeDOS and also MSDOS bootable flash drive and also DVD. Couldn't boot from it. I tried pressing ALT to get to the boot menu but they didn's show up. Tried pressing C to boot from CD, but only booted to OS X. I also tried making a bootable OS X installer usb drive with SFOTT to upgrade to Yosemite, didn't show up either, but worked when I used an INTERNAL drive instead.

    Also, when I put in the graphics card (HD4870) and turned on the MP, the fan started spinning and everything seemed fine, but when I got to the desktop, the PCIe settings window thingy popped up because I had moved my GT7300 to PCIe slot 2 and put my HD4870 in spot 0, and only the GT7300 showed up! I tried booting to windows as well (BootCamp) but couldn't find the HD4870 in the device manager there either!
    And obviously there was no signal when I plugged a display to the HD4870 (tried with DVI-VGA + VGA-HDMI adapter and just DVI-VGA adapter).

    I figured it might just have been a dead card, so I got a Zotac GTX560Ti as well, and this time I made sure to be shown that it worked first, and it did in his computer (self built running Windows 7). Got home, put it in the MP and booted Yosemite, nothing. Booted windows, nothing. Booted Lion, nothing. Tried installing Nvidia drivers in Lion, nothing. The fan sounded like it was running, but that was it.

    So, what could be the problem here? I know I can't expect boot screen, but from what I understand I should be getting a picture after the boot screen, right? And the card should at least be recognized by the computer?

    Thank you all so much for any help you can give!
     
  2. Fl0r!an macrumors 6502a

    Joined:
    Aug 14, 2007
    #2
    Sounds like you forgot the GPU power cables...

    Btw, Macs can't boot legacy OS (FreeDOS) from USB. Needs boot CD & PATA Superdrive on old MPs.
     
  3. anendlessches thread starter macrumors newbie

    Joined:
    Dec 11, 2015
    Location:
    Norway
    #3
    The power cables are there, two 6 pins, which is what both the HD4870 and the GTX 560Ti use, but it's not working regardless..

    and I tried with CD as well, as stated, but that didn't work either.
     
  4. golip macrumors newbie

    Joined:
    Dec 19, 2015
    #4
    could be power not getting to the cards ? possible faulty or flaky psu

    also have you tried plugging just the new card in to slot one as other slots will run slower

    i would verify power by using same cables to your known working cards and also try these in slot one

    If after that you still cant get no joy i would suspect a possible faulty logic board

    ps try a pram and smc reset too
     

Share This Page