Mac Pro not recognizing hard drive

Discussion in 'Mac Pro' started by cwright, Dec 14, 2013.

  1. cwright macrumors 6502a

    Joined:
    Jan 5, 2004
    Location:
    Missouri
    #1
    I have an early 2009 Mac Pro that has stopped recognizing one of it's internal hard drives. From a little troubleshooting it looks like the problem is with the drive and not the computer, but I thought I'd see if anyone else has had this happen.

    I've had plenty of drives fail before, but this one isn't reporting failure - it's just not appearing at all. I had been running 2x 3TB drives in a software RAID 1 setup until recently I saw the RAID had been compromised because one of the drives was missing - according to Apple's Disk Utility. I copied everything off the volume and deleted the RAID. This gave me back one of my empty 3TB drives, but the other one still didn't mount.

    I attached a screenshot showing what the system report shows for the drive bay the missing 3TB drive is in. Right now it's in Bay 2 - but I've tried this drive in all four bays with no luck, and had success mounting other working drives in Bay 2.

    The only difference I can tell so far is that the missing drive lists Native Command Queuing as "No", where all the others list "Yes". Could this have something to do with it?

    Not sure what else to try, besides maybe getting a USB/eSATA hard drive dock, but I suspect I'll have the same problem there. Any ideas would be much appreciated!

    [​IMG]
     
  2. Ccrew macrumors 68020

    Joined:
    Feb 28, 2011
    #2
    Drive more than likely has lost it's controller board. If that happens the drive properties don't exist as there's no communication occurring - hence the machine thinks there's no drive installed. By your screenshot it can see the Intel side of the machine's chipset that talks to the drive controller.

    More often than not it's the heads or the drive motor that dies, in which case the machine can still get info from the drives controller, but can't get to the data. You's is a not totally uncommon but not the most prevalent failure.
     
  3. westrock2000 macrumors 6502

    Joined:
    Oct 18, 2013
    #3
    NCQ is an inherent feature of all (modern) SATA drives. I would say the drive is "dead". :(

    Does Disk Utility see the disk at all? Does it show a S.M.A.R.T status for the drive?
     
  4. cwright thread starter macrumors 6502a

    Joined:
    Jan 5, 2004
    Location:
    Missouri
    #4
    Thanks for the replies. No, Disk Utility doesn't recognize the drive at all, so as you both said it looks like the drive is just dead. I was hoping it might be a simple fix.

    Horrible luck with hard drives lately. I was just trying to free up these two 3TB drives to offload as much as I can from my 21TB RAID 5 volume that is failing :mad:
     

Share This Page