Mac Pro now takes 5 minutes to boot?

Discussion in 'Mac Pro' started by Doc69, Oct 26, 2011.

  1. Doc69 macrumors 6502

    Joined:
    Dec 21, 2005
    #1
    I have an original Mac Pro. Yesterday I installed the security update. After the installation, the computer did not shut down properly. Even holding down the power button did not help. I had to pull the power plug.

    Now the Mac takes about 4 minutes and 30 seconds to boot. I have OS X installed on three individual drives (two SSDs that normally would boot in 20 seconds), both 10.7 and 10.6, and they all, strangely, takes the same time to boot now.

    After the chime sound, most of the time it now takes about 1m 20s for the login menu to appear. Then it takes another 3 minutes before I can actually click on anything. Other times the grey screen turns blue after 1m 20s and then it stays blue for another 3 minutes before the login menu appears.

    When the computer finally has booted, everything seems to work normally.

    Any ideas what might have happened and how to troubleshoot this?
     
  2. 666sheep macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #2
    Reset PRAM and set Startup Disk in SysPrefs to your desired OS. If it won't help, run fsck in single user mode.
     
  3. xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
    #3
    Clear the kext caches:

    sudo kextcache -system-prelinked-kernel
    sudo kextcache -system-caches


    Do in terminal and reboot. make sure your start up disk is still selected correctly in preferences. The above tip works wonders on slow booting ssd's.
     
  4. Doc69 thread starter macrumors 6502

    Joined:
    Dec 21, 2005
    #4
    I did reset PRAM but it didn't make a difference. How do I "run fsck in single user mode"?

    ----------

    Is this going o affect only the system I'm booted up into, or all systems on all disks? Should I run it even if I have the same problem with the system that boots off a hard drive as the ones that are installed on SSDs? And does clearing the kext cases affect anything on my system?
     
  5. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #5
    Only the system you are booted from as you are not directing command to any of the other disks. You'll be fine, the caches rebuild themselves and hopefully in the process, get fixed. Programs like Onyx and the like run these scripts as well.
     
  6. xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
    #6
    I never did this much until I had ssd's and now do it every month or so. The biggest help was the first one. (dramatic difference) If you want, you can secure erase the "free" space in disk utility and then run these commands and that's about as good as you will get other than stopping some startupitems / daemons / agents etc. from auto starting at boot. Again, make sure after all this that your disk is set as your "startup" disk in preferences and a permissions repair doesn't hurt anything for good measure. ;)
     
  7. cosolin macrumors newbie

    Joined:
    Apr 23, 2009
    Location:
    Seattle, WA
    #7
    Since you've already reset the PRAM, I would repair disk permissions. If the list of repaired permissions is quite long, I usually do it a minimum of 3 times. I'm not sure if this is totally necessary, but I was given this instruction on an Apple Care support call once.

    Good luck.
     
  8. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #8
    Cosolin, repair permissions only repairs file access permissions on system folders. No user folders and does not fix very many things unless you have file access issues. It is a very hilarious placebo that inexperienced computer people tell you to do as they have no other idea what is going on. And yes, 3 times is way too many times as usually 1 time is too many. I only run permissions repair before and after major software updates.
     
  9. Doc69 thread starter macrumors 6502

    Joined:
    Dec 21, 2005
    #9
    Changed the CMOS battery and did a fresh install.

    I finally managed to solve the issue. So I'm posting it here for reference.

    I changed the CMOS battery on the motherboard (the Mac Pro is 5 years old). The power left was 3.2v compared to 3.5v for a new one. I then removed all hard drives and added a blank one on which I installed 10.6. And the first reboot was completely normal.

    I then added my main SSD, which up until now had taken 5 minutes to boot. It took about a minute to boot, so better than before but obviously doing something. After a reboot, it then booted normally, 15 seconds to login screen.

    I don't know which of the things that actually solved the problem as I did them together. But I suspect it was the battery.

    Thanks to everyone for your input!
     
  10. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #10
    I really have no idea what fixed or didn't fix your problem, but if it was the battery, I'm surprised the CMOS is so sensitive that 0.3v made a difference.

    I occasionally order lithium coin batteries by the 50 pack and even among the new batteries there is typically more variation than 0.3v.
     

Share This Page