Mac Pro suddenly shuts down.

Discussion in 'Mac Pro' started by ilegal31, Dec 15, 2014.

  1. ilegal31 macrumors member

    ilegal31

    Joined:
    Aug 8, 2014
    #1
    Hello people,


    I have a Mac pro 2,1 running OS X Yosemite, also I had upgraded the graphics card to an Nvidia GTX 570 HD 2.5GB VRAM, the computer runs fine until I open any application then it shuts down, restarts twice and goes back to normal "Sometimes I have to repairr the drive to boot", I had replaced the ram with a kit purchased over E-bay "The seller claims
    is compatible" the ram is recognized by the computer, on the following picture yo guys will notice a red light that remains on after it shuts dow, a friend of mine told me that a faulty Power Supply Unit maigth be the issue, what do you guys think?. Also, the memory boards from a Mac Pro 1,1 will work on a Mac Pro 2,1?.


    [​IMG]

    Thanks.
     
  2. boodaddyz, Dec 15, 2014
    Last edited: Dec 15, 2014

    boodaddyz macrumors member

    boodaddyz

    Joined:
    Dec 25, 2008
    #2
    It could be the power supply. You need to troubleshoot. First, I would take the GTX 570 out, and put your factory card in, and see if the problem still exists. If so, then you have a problem pointed at the card, or power.

    If you have the same issues with the factory card, then you need to look at the ram. I would put the factory ram back in, and see if the problem still exists.

    Yes, the Memory Riser Card from a 1.1 will work in a 2.1
     
  3. ilegal31 thread starter macrumors member

    ilegal31

    Joined:
    Aug 8, 2014
    #3
    Hello boodaddy,


    I had replaced the graphics card and it behaves the same, I no longer have the original ram, I did not had this issue previously, started when I purchased a ram kit over e-bay the ram is generic I noticed that it gets extremely hot, I think probably that is the issue, can you please recomend me a ram brand that is certified and works without problems on a mac pro?.


    I greatly appreciate your time.
     
  4. boodaddyz macrumors member

    boodaddyz

    Joined:
    Dec 25, 2008
    #4
    I would check out OWC they have great Mac memory, with lifetime warranty. I would return your ram you just purchased if you are 100% sure that is the problem... If it's to late to return your memory, OWC has a trade-in program for memory that will get you additional savings.

    Here is the link
    http://eshop.macsales.com/shop/memory/Mac-Pro-Memory#667-memory

    Hope this helps
     
  5. NOTNlCE macrumors 6502a

    NOTNlCE

    Joined:
    Oct 11, 2013
    Location:
    DMV Area
    #5
    How is your boot drive health? Just yesterday, I had to replace the hard drive portion of my fusion drive because the drive was dead. Boot would start, and as soon as I spun up the hard drive, the machine would power off.
     
  6. lowendlinux Contributor

    lowendlinux

    Joined:
    Sep 24, 2014
    Location:
    North Country (way upstate NY)
    #6
    I think it's a power issue, followed by a RAM issue.
     
  7. ilegal31 thread starter macrumors member

    ilegal31

    Joined:
    Aug 8, 2014
    #7
    Hello people,


    I had tested the ram, hard drive and graphics card on another Mac Pro and they work fine, at this point I think the issue might be the PSU.
     
  8. Gav Mack macrumors 68020

    Gav Mack

    Joined:
    Jun 15, 2008
    Location:
    Sagittarius A*
    #8
    With the 570 being a bit of a power hog (330 odd watts iirc) and your old PSU losing a bit of peak power over the years it would be my prime suspect tripping it out when the GPU kicks in properly.
     

Share This Page