Mac Pro w/ Left 4 Dead on 32bit XP freezing

Discussion in 'Mac Basics and Help' started by imperial_68, May 3, 2009.

  1. imperial_68 macrumors newbie

    Joined:
    Sep 24, 2005
    #1
    Hey all,

    I am running an early 2008 Mac Pro:
    4GB ram (only 3 running in XP)
    Dual Intel Quad-Core Xeon 2.8 GHz
    ATI Radeon HD 2600 256MB

    So over the last couple months, I've been getting some extremely bad and annoying freezing problems when playing Left 4 Dead on 32bit Windows XP Home Edition. The last sound played repeats over and over again with the screen freezing; this has lasted anywhere from 5 seconds - 40 seconds. My frame rate doesn't seem to be making a huge difference, its consistent at 45-60 fps when its on pretty simple settings:

    Anti-Aliasing: None
    Ansiotropic Filtering: Trilinear
    Vertical Sync: Disabled
    Multi-Core Rendering: Enabled
    Resolution 1650x1050
    Shader Detail: Medium
    Effect Detail: High
    Model/Texture Detail: Medium
    Paged Pool Memory: High

    At first I thought it might be my Graphics card over heating but tonight I tried it with the case open and a very powerful fan blowing air directly onto the card and the problem continued. If anyone has any ideas please, please help me out! I hate to think that I can't play this game when this computer has such good hardware. PS. this hasn't happened with any other games but it doesn't run Crysis very well but thats obvious because well...its Crysis and even with it I have higher settings on. I've also cleared the computer of any spec of dust, just so you know.

    THANKS!:(
     
  2. aaronw1986 macrumors 68030

    Joined:
    Oct 31, 2006
    #2
    The only thing I could think of is maybe the sound drivers? I just got that game the other day. It runs fine for me in 64 bit Vista with everything setting on the highest. If it works in 64 vista, I don't see how it would have trouble in XP. :(
     
  3. ryannazaretian macrumors 6502a

    ryannazaretian

    Joined:
    Sep 21, 2008
    Location:
    Mississippi
    #3
    On my MacBook Pro, the Multicore Rendering will freeze up my game for a few seconds. You can try that, but it seems like you're freezing up too much.
     
  4. imperial_68 thread starter macrumors newbie

    Joined:
    Sep 24, 2005
    #4
    Hmm, I don't think its the sound drivers 'cause I don't think that would effect the visual aspect, the screen freezes too if I forgot to say that.

    I tried turning off the multi-core rendering too but it kept happening, I'm worried it has something to do with my GPU.

    Thanks for your help though guys!
     
  5. kntgsp macrumors 6502a

    Joined:
    Jul 27, 2004
    #5
    I had that exact problem on a Late '08 15" MBP with 512MB GPU. The solution for me was the wireless driver and updating the sound driver. The Boot Camp drivers for Airport cards and onboard sound are woefully outdated. Find the device ID and get the latest update from the manufacturer.

    After that, download the latest Windows driver for your card. Install if over the Boot Camp drivers. The only thing Boot Camp drivers are good for are the proprietary devices like iSight, displays, keyboards, etc.

    But for off the shelf components, ALWAYS install the latest PC drivers when in Windows.
     

Share This Page