Mac Pro w/Vista 64-bit - Superdrive can't read discs

Discussion in 'Mac Pro' started by matt321, Feb 27, 2008.

  1. matt321 macrumors member

    Joined:
    Oct 27, 2007
    #1
    Hey guys I didn't know if anyone else has had this problem.

    I just got a mac pro (2006/2007) and Installed Vista Ultimate x64 from a DVD. When I rebooted and got to the Vista desktop, it no longer lets me used the superdrive. I can eject it from Vista but when I insert a disc, all it does is spin up forever and lock up Vista.

    I have reloaded Vista 3 times and get the same issue. Everything else works except the superdrive.

    Any ideas?

    Thanks!
     
  2. matt321 thread starter macrumors member

    Joined:
    Oct 27, 2007
    #2
    Common... Somebody must have a clue ;-)

    I've seen where others have installed Vista x64 on a Mac Pro... what drivers did you use to get it going?
     
  3. OnePumpChump macrumors regular

    OnePumpChump

    Joined:
    Nov 19, 2007
    Location:
    Cleveland, OH
    #3
    I installed Vista 64 on the early 2008 macpro and didn't have any problems. I installed Vista first, then put in the leopard disk, which read just fine. Then there is a folder listed on the Leopard disc called "Apple" that contains the drivers that I used, however, I don't recall any pertaining to the superdrives.
     
  4. sturob macrumors regular

    Joined:
    Nov 20, 2005
    Location:
    Houston, TX
    #4
    That's very weird.

    I have an '08 MP, and you need to have the SuperDrive running to complete the installation of Vista.

    Hmmmm. Have you looked around the Apple.com support area to see if you can download the BootCamp drivers? I wonder if there's something in there that would clean up the SD behavior for you. Honestly, mine's had no problems with the SD, but it is a different model MP.

    Have you tried loading any other versions of Windows, to see if the SD is recognized correctly?

    Stuart
     
  5. matt321 thread starter macrumors member

    Joined:
    Oct 27, 2007
    #5
    I haven't tried any other versions of windows yet... it's a last resort since I will lose the extra ram.

    I have looked around apple's site and this forum to see if anyone else has had the issue but haven't come up with anything. It is weird since it will allow the SD to install windows but on the final reboot, when I get to the desktop, SD isn't able to read discs.

    Is it something to do with the chipset drivers?
     

Share This Page