Mac Pro Wants to Shut Down All The Time

Discussion in 'Mac Pro' started by askipper, Dec 15, 2008.

  1. askipper macrumors member

    May 3, 2008
    For some reason, my Mac Pro wants to shut down all the time. Every 10 mins or so the message, "Do you want to shut down etc. etc." comes up with the usual options of Restart/Sleep//ShutDown or Cancel. I click on cancel and it goes away for 10 mins, sometimes less, sometimes more.

    No idea what's causing this at all. I normally keep it turned on all the time but I went away for the weekend so I shut everything down in the office - I know it got pretty cold in there (maybe even freezing) so I'm worried I've done some damage due to the cold?

    Nothing has been installed but I have no idea where to check or what to do now. It's my main computer - I use it for work all the time and would be at a loss if I needed to send it away so I'm hoping someone will have heard of this and have a solution

    I;ve searched around a lot and all I can see is people having trouble to get their macbook's to shut down - this is the other way around!

    Oh, Mac Pro, 4 quad intel, 4gb ram I think and 750gb hard drive. The power is connected to a UPS but that doesn't seem at fault.

    It seems to be only doing it when I'm away for a while - maybe when it's trying to sleep or shut down the hard drive? I did have it set to Never for going to sleep and I have changed that last night so it's not the Sleep side of things. I will try unticking the Put the hard disk to sleep now and see if that makes a difference. I also see the option "Allow power button to sleep the computer" so if the previous attempt doesn't work I'll try that - I suppose that will identify whether it's the power button or not

    Please help

  2. askipper thread starter macrumors member

    May 3, 2008
    Just in case anyone finds this with same problem later on the problem was the Cinema Display Power Button as when I configured the power button to NOT do anything the problem stopped. When it was configured to put the system to sleep it kept coming on when the system tried to sleep itself or whenever it felt like it.

    So, another visit back to the Apple shop along with my imac that has developed a 1 pixel high horizontal line at the bottom of the display for no reason! Now I have to take a 30" ACD too :-(
  3. ds88 macrumors newbie

    Feb 23, 2009
    Mac Pro Wants to Shut Down All The Time

    I was having a similar problem with my MacPro3,1 2x2.8GHz Quad core Intel Xeon with 30" Cinema HD Display.

    It would randomly pop up the "shutdown message" to the front of the screen. Other times, it would randomly dim the screen to the minimum brightness. If I tried to override it by holding the "increase brightness" key, then it would dim back down as soon as I let go of the brightness increase button.

    We tried what Apple Support suggested (including resetting PRAM and unplugging all cords and waiting 1 minute). That did not work. :(

    The last thing I tried was unplugging the keyboard wire from the back of the MacPro and instead plugging it into one of the USB slots in back of the Cinema Display. As soon as I did that, the problems stopped. :)
  4. FastMan macrumors member

    Jan 9, 2008
    Just wanted to post a thanks to the posters here.

    I had the same problem. "Are you sure you want to shut down" window would repetitively pop up, similar to the guys above, and would dominate the screen until I hit cancel. Could hit cancel, and the message would just keep repeatedly popping up as fast as I could hit cancel. It was something buggy in my 30 " cinema display power button. I went into system preferences > displays > options > and changed the power button function to "do nothing". Problem fixed.

    Hope others with the same issue find this thread.
  5. billd macrumors newbie

    Nov 23, 2010
    --- Post Merged, May 24, 2016 ---
    Same problem, shut down dialog that kept coming back each time I clicked cancel.

    Previously running 'repair disk permissions' with Disk Utility repeatedly seemed to cure it temporarily. Then problem would return after a sleep.

    Changing the system prefs dialog to 'do nothing' for the 30" cinema display cured the problem.
  6. ahmeier macrumors newbie


    Sep 7, 2014
    Syracuse, NY
    this worked for me, too.

    Mac Pro 1 1 30'' Cinema display El Capitan 10.11.6 pikified

Share This Page