Mac Pro wireless problem

Discussion in 'Mac Pro' started by dblester, Feb 15, 2012.

  1. dblester macrumors member

    Joined:
    Jan 8, 2008
    Location:
    Atlanta, GA
    #1
    The other day i ran software update and updated my early 2008 mac pro to the latest software. Upon completion my computer restarted like usual, but now my computer does not see my airport card it says that there is none installed. Ive tried resetting my computer but that doesnt work. When i boot into Windows the wireless works fine no problems, but the mac side thinks that I do not have an airport card installed. Is anyone else having this problem?. The Apple Store is kind of annoying to get to, so I am trying to avoid setting up an appointment.
     
  2. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #2
    You don't say which version of Mac OS you started with and if there was any other software updated.

    If you went from 10.7.2 to 10.7.3, I suggest downloading and installing the combo updater for 10.7.3. Sometimes the delta updaters miss stuff.
     
  3. jamesmar macrumors newbie

    Joined:
    Feb 15, 2012
    Location:
    London, UK
    #3
    I'm having the same problem on my Mid 2010 Mac Pro - I'd been running 10.7.2 for a long time without any problems until I booted up one day a few weeks ago to find the 'Wifi: No Hardware Installed" message in the menu bar. Very frustrating, I can manage using ethernet for now but it's a real pain.

    First I tried logging into another user account - same problem. Booting into safe mode also gave same result. In Network Diagnostics, everything came up as failed.

    I have Applecare - called them last week and they told me to try a few things:

    - Reset SMC
    - Boot into Lion recovery mode
    - Run Apple hardware test (both standard and extended tests)

    Resetting the SMC didn't work, still no Wifi in Lion recovery mode and the hardware tests said no problems found - not sure if this would be able to find a wireless problem?

    I have also tried:

    - Booting into Snow Leopard on an external disk (I don’t have Windows installed so I’m unable to try that)
    - Resetting the PRAM
    - Temporarily downgrading the Airport driver to v3.2 using a kext utility (this fix was originally intended for iMacs when Lion was released but thought it was worth a shot)
    - Updating Airport Utility to 6.0
    - Updating the OS to 10.7.3 (combo updater)

    Again, none of these fixed the problem.

    In System Profiler/Network there is no entry for 'Airport' - not sure if there should be. When you click on WiFi it just lists software versions for things like CoreWLAN, CoreWLANKit etc. The person I spoke to on the phone said there would be nothing in the WiFi entry if it was a hardware issue.

    Before I call Applecare again, does anyone else have any suggestions? Any help much appreciated.

    I've got a feeling it's either a driver issue or my wireless hardware has died...
     
  4. wilsonhaven macrumors member

    Joined:
    Oct 12, 2009
    #4
    @JamesMar, any update?

    I'm not certain when this started for me because I'm usually hardwired. I have a MBP 5,3 running 10.7.3. I recently deleted an IPSEC interface that I no longer need. My other recent change was installing an SSD into the superdrive bay and making it the boot drive. I installed lion on SSD (lion also on the original boot device) and then used the migration assistant to get the apps and user on to the ssd.

    This problem seems to be fairly common. Has anyone resolved this? Can I use BSD methods to create a new airport device?

    Thanks.
     

Share This Page