Mac Pro with Medialink & PS3. All video stutters over wired network

Discussion in 'Apple TV and Home Theater' started by spdorsey, Mar 3, 2011.

  1. spdorsey macrumors newbie

    Aug 25, 2010

    When I purchased Medialink, it worked great!

    Now, when I play any video (HD or SD), the video stutters and playback is unwatchable. Movies play back fine on the Mac. This issue has been happening since about February 20th (I'm guessing).

    I'm on a gigabit wired network, and every machine (Mac and PS3 included) has a static local IP.

    Network test on the PS3 sees Playstation NEtwork, gets an IP, but UPNP fails.

    What can I look for? How can I fix this?

  2. haoledoc macrumors member

    Jan 24, 2011
    Over time I had a lot of trouble with Medialink, with frequent stuttering as you describe. I've had much better luck with PS3 Media Server. It's free and pretty easy to set up. You may need to forward 1 or 2 ports in your router to make it work.
  3. spdorsey thread starter macrumors newbie

    Aug 25, 2010
    Port Numbers

    Would you happen to know what the port numbers are that I would need to forward?

    Also, do I forward those ports to the machine that sends the Upnp stream, or the machine that receives the stream?

  4. haoledoc macrumors member

    Jan 24, 2011
    I just checked my router config and it looks like I have port 5001 forwarded for both TCP and UDP to the computer acting as the server. I don't know if it always uses this specific port, I'm sure I just pulled it from the program settings somewhere.
  5. whooleytoo macrumors 604


    Aug 2, 2002
    Cork, Ireland.
    This doesn't really help (sorry), but I was never able to get video to play as reliably on my PS3 as on my 360 (same Wifi network, same media software, same video). I even moved the PS3 to wired and it made little difference.

    Rivet was the best for me, but even that wasn't perfect.
  6. fosterpants macrumors newbie

    May 12, 2010
    PS3 Media server works reliably for me from my MBP to PS3 over wifi. I didn't have to forward ports (at least not that I remember).

Share This Page