Mac Pro won't sleep by itself

Discussion in 'Mac Pro' started by Richard Flynn, Jul 20, 2010.

  1. Richard Flynn macrumors regular

    Joined:
    Sep 4, 2006
    Location:
    Sydney
    #1
    Hope someone here can help. I've been reading things all over the Web for at least the past week on this and haven't found a solution for my problem.

    Basically, my Mac Pro (2009 octo 2.93GHz), which is just over a month old [gave up waiting for 2010 models] won't go to sleep by itself.

    When I first set everything up, the computer would sleep by itself like a proper little trooper.

    The problem seemed to start after I installed a Sonnet Tango FW800/USB PCIe card, even though Sonnet claim that that card works fine with Mac Pro power management. Even after I've removed the card, the computer still won't sleep by itself. I deduce therefore that the card wasn't the problem.

    At the moment I've unplugged all peripherals apart from the USB connection to my ACD to connect to the keyboard and Logitech mouse receiver.

    I've turned off Bluetooth, turned off Wake for network access, turned off all sharing services. I've reset the NVRAM and the SMC. I've booted into safe mode a couple of times to run an automatic fsck and clear the various caches. Nothing works. The computer won't sleep by itself.

    I've tried both PleaseSleep and Lights Out. Neither works, and, incidentally, they both strike me as hacky, undersupported apps.

    I've tried quitting all open applications and leaving the computer but it still doesn't go to sleep by itself. The screen turns off when it's supposed to, but the computer never sleeps.

    I've got 16GB of OWC RAM installed, and hard disks in all four bays. But the computer used to sleep with this configuration. Like I say, I've now taken out the Sonnet Tango PCIe card in an effort to isolate the problem.

    Can anyone give any suggestion to fix this? I'm reluctant to start reinstalling everything but I wonder if that won't just be less time and effort than everything I've gone through so far. The computer is set to wake up every night to do a local mirror backup (SuperDuper) and network backup/sync (ChronoSync). It's really irritating to find it still wide awake when I come to it later in the day.

    *Insert typically over-blown comment about 'so much for just works' or similar*

    Help me MacRumors, you're my only hope. Seriously, most other forums about the place are pretty rubbish.
     
  2. WardC macrumors 68030

    WardC

    Joined:
    Oct 17, 2007
    Location:
    Fort Worth, TX
    #2
    I know the sounds really dumb, but have you gone to your Energy Saver Control Panel and checked everything out?
     
  3. Richard Flynn thread starter macrumors regular

    Joined:
    Sep 4, 2006
    Location:
    Sydney
    #3
    First principles: excellent. And yes, I have fiddled with everything (I think) in Energy Saver, as well as deleting my com.apple.AutoWake.plist and com.apple.PowerManagement.plist files and then re-setting everything in Energy Saver.
     
  4. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #4
    Download PleaseSleep, it forces it to sleep when it's time to. Usually there is a 3rd party app blocking the sleep so it's extremely hard to fix it, I've spent hours fixing mine but PleaseSleep did it in 2mins
     
  5. Richard Flynn thread starter macrumors regular

    Joined:
    Sep 4, 2006
    Location:
    Sydney
    #5
    Thanks for replying, Hellhammer, but as I wrote in my original post, I've tried both PleaseSleep and Lights Out to no avail.
     
  6. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #6
    Oh, sorry :eek:

    Do you still have the original RAM? When did this begin? Have you repaired permissions with Disk Utility?
     
  7. tomscott1988 macrumors regular

    tomscott1988

    Joined:
    Apr 14, 2009
    Location:
    UK
    #7
    This might be a stupid question too, but have you added a 3rd party optical drive, i added one to my mac pro and it stopped it sleeping. The disc would check every 10 mins or so and stop sleep. Also have you checked your activity monitor for any 3rd party aps running in the background? also have you checked your boot list of aps there might be something in there stopping sleep functioning.
     
  8. Chrisbbarnes macrumors newbie

    Joined:
    Jul 21, 2010
    #8
    Mac Pro never sleeps

    I too have a similar problem, in that my Mac Pro (Dec 2007) has never slept by it's self. Similar config all four HDD bays used with Apple memory and the rest of my 16GB from OWC. Sonnet Firewire and usb card. I do however have one addition in that my machine has ran from new under a APC Smart-UPS 2200va.

    It never sleeps under main power or under UPS power. I have always thought it was something to do the the UPS as I have never been able to get it to sleep under test low battery conditions etc. I thought is was a problem with APC not updating software since 2006.

    P.s. I too have a third party optical drive.

    Might check to Apple Care as I have only a few months left.
     
  9. Richard Flynn thread starter macrumors regular

    Joined:
    Sep 4, 2006
    Location:
    Sydney
    #9
    They all sound like good questions.

    I have still got the original RAM, but this problem started at least a week after I installed the OWC RAM (the sleep problem started just over a week ago from today). The OWC memory (on the Nehalem Mac Pros) can't be installed at the same time as the Apple-supplied RAM (grr).

    I haven't got any third-party optical drives; just the SuperDrive which identifies itself as ‘GH41N’ supplied with the machine.

    I might also add that if I put the computer to sleep myself (from the menu or with the keyboard shortcut) then it stays asleep until it's woken properly—either by my physically waking it up, or when the nightly scheduled wake event comes due.

    I'd be interested to know, Chrisbbarnes, if you get anything helpful out of Apple on this matter. I've read loads of stories of problems like this all over the Web; some have been solved through the various techniques I've already tried while others just go unanswered, like cries in the wilderness.

    And yes, I've tried repairing permissions. Obviously I don't know which process, if any, is preventing auto-sleep but I don't think I had any major changes in my software setup at the time this all started.

    ETA: I also made a new (blank) user account on the machine, to see if that would change things. The computer doesn't go to sleep on its own when logged into that account, either.
     
  10. harleymhs macrumors 6502

    Joined:
    Jul 19, 2009
    #10
    Hey, Im sure this will help you! I too have a mac pro (2008 ) Had the same issue like you have, NO SLEEP, force it to sleep and it did, auto sleep nothing! I have a back up of an Leopard on a ext drive, when I boot up into that drive it sleeps! When I boot up into snow leopard on my internal drive NO SLEEP! The mac pro came with leopard and when I went to snow leopard all was well then ONE day NO SLEEP! 4 HD in the bays 12 gb ram. No hard ware changes! Went to Apple made an appt with the genious. They did the same thing booted up into another drive and it slept! Now they tell me its Snow leopard and Mac Pro! That wasnt a good answer! So I went home and called apple care and I paid for apple care so I wanted a new machine! Now a senior tech got on the phone he emailed me a program to run on my system then when it was done ( 20 min ) he told me to email it back to him! Then he would foward the file to the APPLE and the engineers would get back to hima dn he would get back to me ! Yea right! Well HE DID ! ! They told me the FILE that was keeping my mac pro from sleeping. I removed the ONE file and it SLEPT!!!!!!!! ( it was an epson printer frover file) Hope this helps!!!! If you want to fix it NOW , just do a FRESH install of OSX and load yoru programs back one by one and set it to sleep in 1 min and keep checking after each program install!
     
  11. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #11
    Take out the OWC RAM and put the original in it. Worth a shot IMO. Then if it works, drop OWC a line, maybe they know why it ain't sleeping with their RAM
     
  12. Jaddie macrumors newbie

    Joined:
    Jul 21, 2010
    #12
    Me, Too

    Dear Tom Scott & Friends

    My 2007 Mac Pro won't sleep, either, with the third-party optical drive installed. If I put a disc in the drive, though, it will sleep.

    I'm going to try PleaseSleep.

    --Jaddie
     
  13. tomscott1988 macrumors regular

    tomscott1988

    Joined:
    Apr 14, 2009
    Location:
    UK
    #13
    The only remedy i had for this was to remove the drive, so i did and i have been using just the one superdrive it came with. But mine kept searching for a disc every 10 mins or so, thats why the pro wouldnt sleep.
     
  14. Richard Flynn thread starter macrumors regular

    Joined:
    Sep 4, 2006
    Location:
    Sydney
    #14
    OK, my situation is this. I put the computer to sleep last night as usual (it's now Thursday 10.50am here). When I got to it this morning, it was sleeping again, even having woken up on schedule to do its backup at 3.30! However, after leaving it again, once more it didn't go to sleep on its own.

    I've now swapped the OWC RAM back for the Apple-supplied RAM. However, that still seems not to have fixed anything—the computer is still wide awake even though I left it for nearly an hour (I have it set to sleep after 15 minutes).

    I suspect that this weekend I'm going to have to wipe and reinstall the boot disk to see if I can get it working again. I think I'll reinstall with the OWC RAM and the Sonnet PCIe card in place (both of which have now been taken back out of the machine). Today though I'm going to have to get on with some work, I fear, which precludes much computer-tinkering.

    If anyone has any more suggestions, I'd be delighted to hear them.
     
  15. J the Ninja macrumors 68000

    Joined:
    Jul 14, 2008
    #15
    Do you sometimes leave Terminal windows open? There's a power management setting, which is enabled by default, called "TTYsKeepAwake" that well....makes terminals keep it awake. I honestly haven't figured out if it is "Terminal logins prevent idle sleep" or "The terminals must all have been idle for the 'idle sleep' time as well", but unless this is disabled (you will need to use pmset or hand-edit the plist file) an open terminal can affect idle sleep.

    Also, what are your disk sleep settings? If your disks aren't allowed to idle to sleep, the computer itself might not idle to sleep. Lastly, as a result of this, setting the sleep timer to 1 or 2 minutes to see "if it goes to sleep" is sadly not an accurate way to diagnose idle sleep issues.

    Give this a read if you haven't before, it's the power user docs on OS X's power management system: http://developer.apple.com/mac/library/documentation/Darwin/Reference/ManPages/man1/pmset.1.html (you can get to it locally by running "man pmset". You can find it online by typing that command into Google)

    -J the Ninja, who still doesn't know why his Mac only sometimes idles to sleep.
     
  16. Richard Flynn thread starter macrumors regular

    Joined:
    Sep 4, 2006
    Location:
    Sydney
    #16
    Thanks, J the Ninja, it’s comforting (sort of) to hear of someone who's possibly gone more in-depth on this than I have, even if you are still stumped.

    I haven't been leaving Terminal windows open, and no other computer was SSHed into my machine or anything like that.

    I had previously been playing around with pmset; I hadn't found the man page on the Web, though, which is so much easier to read than in the Terminal itself. What's funny is that the man page doesn't mention the -g log argument which I've read about elsewhere. When I run that I frequently see something to imply that either the Kernel or mDNSResponder is preventing sleep (com.apple.powermanagement.applicationresponse.slowresponse). Looking at that, and the various plist files maintained by configd, I've been trying to fiddle with my network settings—this was my principal motivation for turning off ‘Wake for network access’ (or womp in pmset), deleting settings for individual interfaces, and just now turning off Back to My Mac completely. But I'm still not seeing anything promising.

    When I get a chance I think I'll reinstall all my hardware (new RAM, Sonnet PCIe card, plug all the other peripherals back in) and investigate running the OS X installer as an upgrade in place. I'll see how that goes. Assuming that doesn't work, I'll wipe the drive and rebuild from scratch in the hope to cure the poor computer's insomnia.
     

Share This Page