mac running Leopard, does not detect ANY USB printers..Ugh!

Discussion in 'MacBook Pro' started by kyotik, Oct 30, 2012.

  1. kyotik macrumors newbie

    Joined:
    Oct 30, 2012
    #1
    My MBP running Leopard, used to print fine wireless. I'm no longer using my airport extreme express and share a wireless connection with my neighbor, who has a PC.

    I have a Brother laser HL-2140 printer that I am trying to install by USB. I have downloaded all new required drivers, followed the steps exactly and for some reason my MBP will not recognize this or any other USB printer. I've changed USB cables, and USB ports. The only printer that it detects is Adobe pdf 9.0. I am SO FRUSTRATED, does anyone know what I am doing wrong??
    I would appreciate ANY help..please!
     
  2. applematic macrumors newbie

    Joined:
    Mar 1, 2011
    #2
    Have you tried a NV/Pram reset?

    Have you tried a NV/PRam reset? this may help if you have ever been able to print via usb before...also go to system profiler and see if the usb is recognizing something being plugged in.

    Here's an article on how to reset the pRam....

    http://support.apple.com/kb/HT1379

    Hope this helps

     

Share This Page