Mac runs slow when using 1080p monitor

Discussion in 'Mac Accessories' started by buckers, Apr 3, 2012.

  1. buckers macrumors 6502

    Joined:
    Aug 18, 2010
    Location:
    Anglesey, UK
    #1
    Hi; I recently received a 22 inch 1080p TV which I decided to use as a monitor by hooking up to my MacBook Air with an HDMI cable. Unfortunately, when running at 1080p on Mac OS X, the whole computer becomes sluggish; not just a low frame-rate; it takes web pages and documents far longer to load than normal, and I can't watch any videos full screen because they get very choppy.

    What's interesting, is that when I boot into Windows using Boot Camp, everything's really responsive, like it normally is; no slow down. :confused:

    I just think it's strange to think the laptop can't cope with such a large display when running OS X (don't people hook these things up to those huge Apple Cinema Displays?), and was wondering if anyone had any advice?

    Spec of laptop:
    • 2.13GHz C2D
    • 4GB RAM
    • NVidia 320M
    • SSD with 12GB free
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    OK. You don't judge a display by its geometric size but rather by its number of pixels. The fact that you have a 22" display is irrelevant. Your display's important specification is 1080p It is 1080p, isn't it? This means that its pixel density is 1920x1080. As such, it is not a large display. Your MacBook Air supports external monitors up to 2560x1600. This is more than 4 times the number of pixels in a 720p HD display. The bottom line is that you have ample power to drive the meager number of pixels in a 1080p display.

    You should check your settings in the Displays preferences pane.
     
  3. buckers thread starter macrumors 6502

    Joined:
    Aug 18, 2010
    Location:
    Anglesey, UK
    #3
    Thanks for your reply. I've been trying 1080p and 1080i resolutions with 50Hz and 60Hz settings, all of which look the same and the computer runs sluggish. I'm not on at the moment, but I'll try a lower resolution (1400x900 or 1280x800) to see if that helps.
     

Share This Page