Mac SMB share killed on reboot - every time

Discussion in 'OS X Mountain Lion (10.8)' started by arvetus, Feb 23, 2013.

  1. arvetus macrumors newbie

    Jan 10, 2013
    I might be able to search for this, but I haven't had much luck in googling either, which brings up a number of results that either don't apply or haven't worked.

    I have a Windows 7 machine on my network that I want to access files that are on my Mini with ML 10.8. I have the folders shared out with SMB and initially it worked great.

    After a reboot of the Mac, I could not access the Mac share from the Windows PC. I went in and fiddled with the settings again and it worked.
    Reboot killed it again.

    I came to the conclusion that unticking and re-ticking the SMB share option in the Sharing pane does the trick, but I don't want to have to do this every time I reboot the Mac.

    Has anyone seen or found a fix for this?
  2. drambuie macrumors 6502a

    Feb 16, 2010
    I've been experiencing the same issue with my new 2101 27" iMac with 10.8.2. There's no sharing problem between my Win 7 PC and MBP with 10.6.8, or iMac and MBP, in both directions. My iMac has no problem connecting with my PC, but as you said, to establish share permissions for the PC to connect with the iMac after, I have to disable, then re-enable SMB sharing. This stays valid until the next boot-up.
  3. Imac Sam macrumors 6502

    Imac Sam

    Oct 9, 2011
    Harrisonburg, Virginia

    Yep I have the same issues. Does your Imac have an SSD? I think the bug is more common on SSD equipped machines.
  4. ScoobyMcDoo macrumors 65816

    Nov 26, 2007
    Austin, TX
    You should report this bug to Apple.

    As a work-around until this is fixed, you could enable ssh (Remote Login), and use winscp from your windoze box.
  5. arvetus thread starter macrumors newbie

    Jan 10, 2013
    Aahh!! That might make sense. I thought it had worked fine before I built a fusion drive array with a 256g crucial m4 and the OEM apple drive. Thought I was just imagining things....
  6. drambuie macrumors 6502a

    Feb 16, 2010
    Once you know thw workaround, it's really just a minor inconvenience. It only takes a few seconds to flip SMB Off then On. Most times I exchange files between my PC and my Macs I do it from the PC. I find it faster to navigate the Macs with Win Explorer than navigating the PC with Finder. Long time Mac users may find it to be the opposite, so I guess it's whatever you're used to. I do have the 1TB fusion.
  7. arvetus thread starter macrumors newbie

    Jan 10, 2013
    It's not a huge inconvenience, but sometimes I RDP into my Windows box and the only way I can access the shared folders on the Mac is with a mapped drive or fqdn path.

    Oh well...maybe they'll fix the bug in an update...
  8. stiwi macrumors regular

    Nov 13, 2010

Share This Page