Mac sometimes (!) does not go to sleep after idle

Discussion in 'macOS' started by jijitrash, Apr 13, 2011.

  1. jijitrash, Apr 13, 2011
    Last edited: Apr 13, 2011

    jijitrash macrumors newbie

    Joined:
    Mar 7, 2011
    #1
    I found a couple of older posts about this issue, but in many of them the inital question could not be answered:

    there seems to be a bug in Snow Leopard that prevents sleep after idle uder certain circumstances.

    Mal 2011 Macbook Pro does not go to sleep reliably for one of the users, whereas it does for other users on the machine. I deactivated most of the AutoLaunchedDaemons, and cannot see what prevents sleep. Also strangely enough sometimes it does go to sleep for my user account.

    In the console log I could not find anything obvious that prevents sleep. Energy saving settings are set to minimum time, with or without hard drive sleep. I deleted the plist file several times and recreated it. Also, I am not running flash videos, or itunes music, or a DVD. These would be obvious causes, and you can rule them out. Even after boot it struggles sometimes.

    How would you approach this problem? Where to look for errors? When I check the log file of pmset (by displaying it as pmset -g log>sleep.txt, then in my user folder there is the log file) I don't see what prevents sleep. For now I have PleaseSleep installed, but I believe a 2000 GBP laptop should be able to do sleep after idle, no?

    also, I tried resetting PRAM and SMC.

    thanks for any tips.
    james
     
  2. jijitrash thread starter macrumors newbie

    Joined:
    Mar 7, 2011
    #3
    Thank you for pointing this out.
    I know this article and went through the possible causes.

    It is a laptop and it happens even without any attached devices. Bluetooth disabled. No waking from network. All sharing (screen, files, printer, internet, etc... deactivated.
     
  3. darksid3r macrumors newbie

    Joined:
    Apr 13, 2011
    #4
    Hey jijitrash,
    I'm having the same problem on a 2010 I7 15" MBP. It's driving me crazy. My symptoms are the following:
    - MBP goes to sleep with no problem after a fresh reboot
    - After a while (not a fixed amount of time), sleeping mode breaks down: when i manually set it to sleep it tries to go to sleep but immediately wakes up. When i close the lid and reopen it after a while, the screen is black but the back light is still on and the mouse pointer is visible on the screen. When I press a key, the computer goes to sleep and quickly wakes up again.
    Same as you, have tried different things, including quitting all the possible processes, using Pleasesleep, deleting the plist files, etc. with no result nonetheless.

    Please let me know if you have the same (or similar) symptoms.

    Cheers,
    DS

    PS I've installed Lion on a different partition, and it seems that the problem is not present (havent used it that much tho).
     
  4. jijitrash thread starter macrumors newbie

    Joined:
    Mar 7, 2011
    #5
    hi,
    the behaviour of my machine is very different: the only problem is that (sometimes) it does not go to sleep after the specified idle time. When it does, or when I sleep it via the menu, it wakes up as expected and there are no other problems. It does not have trouble with the wake up, nor the manual sleep.
    I hope you find the problem. Can you see in the console what is going wrong?
     
  5. darksid3r macrumors newbie

    Joined:
    Apr 13, 2011
    #6

    I have no issues with waking up, only sleeping :). Haven't used the console to check things, do u have any suggestions on what could i do using the console?

    Thanks
    DS
     
  6. jijitrash thread starter macrumors newbie

    Joined:
    Mar 7, 2011
    #7
    is Firefox the problem?

    I found by testing that firefox is very likely the source of my problem (no sleep after idle).
    There has been a bug report on this matter on the Mozilla site since the beta versions of FF3, but somehow the developers are taking it easy with this problem.

    Also, when you try to debug your problem, wait for sleep after idle for up to 10min, even when it is set to 2 min (screen off after 1min, and sleep after 1min). The actual time it takes to go to sleep varies between 2 and 12 minutes for me (if it goes at all). With Firefox running I can wait for hours and it will not to to sleep (as reported by other firefox mac users).
     
  7. darksid3r macrumors newbie

    Joined:
    Apr 13, 2011
    #8
    hmm...

    It seems that's not the cause, likely to be something else... When i get this problem i check the log and get this:
    Wake: Success - AC 100 - EHC1
    I'm trying to figure out what EHC1 is...

    Cheers,
    DS
     

Share This Page