Mac stuck in startup

Discussion in 'MacBook Pro' started by Condork19, Jun 18, 2013.

  1. Condork19 macrumors newbie

    Joined:
    Jun 18, 2013
    #1
    I was recently grounded by my parents, so I had to give up all of my electronics. When I handed over the Mac, I wasn't aware that it was in sleep mode. So it was firmly locked away for a month in sleep mode which I'm sure is very bad. So I got it back today, and as soon as I turned it on I had to update Itunes and Adobe Flashplayer. A tab came up, stating that I needed to restart my computer. I restarted it with no trouble, but I thought that it would be a good idea to let my mac rest for a couple minutes before I started using it again. So I shut it down, but when I tried to turn it back on there was only a grey screen with the Apple symbol and a loading wheel below it.
    When I go to Disk Utility, I can not repair the hardrive. Instead, a tab comes up saying that I must backup as many files as I can, re-format the disk, and then restore the backed-up files. How do I do those things and what could have caused this?

    It will not go into Safemode, and resetting PRAM and NVRAM results in the unchanging grey screen although I do hear the second chime. When I put it into verbose mode, the last thing the terminal reads is:

    'kernel is LP64 [I0BluetoothHCIController : :setConfigState] calling registerService'

    I went to the recovery hardrive, but could not install Lion, since the hardrives were locked. I don't have a backup in TimeMachine. My laptop is a 13" OS X MacBook Pro Lion.
     
  2. skofgar, Jun 18, 2013
    Last edited: Jun 18, 2013

    skofgar macrumors newbie

    Joined:
    Jun 18, 2013
    #2
    Are you talking of this screen?

    [​IMG]

    If yes that should be totally normal...


    • The operating system partition cannot be repaired unless you are booting from the recovery partition. However you may repair the permissions
    • How do you get into Disk Utility if you are not able to boot? Did you try using the recovery partition?


    I have never heard of this tab/window… does this appear when you start your mac and wait? is it possible you could make a picture of it and post it?


    Maybe it is worth a try to use the Safe-Mode… just to check if it would boot (Booting in Safemode usually takes a few minutes longer than normal boot)


    Is your hard-drive encrypted by Filevault 2
     
  3. Condork19 thread starter macrumors newbie

    Joined:
    Jun 18, 2013
    #3
    I am aware that that is completely normal, however the loading screen has stayed that way for about four hours with no completion.


    I went to the recovery hardrive by pressing 'ctrl+r' at the startup. I had the option of using Time Machine, which I can not since I ahve no back-ups. I had the option of installing Lion, which I can not because the hardrives are locked. I had the option of seeking online help from the help section on the Apple website, but it hasn't been too helpful. I lastly had the option of using Disk Utility to verify the permissions, and to repair the disk but I can not. A tab came up saying that the disk could not be repaired and that I needed to back-up as many files as I could, re-format the disk, and then restore the backed-up files.

    I already tried to get into Safe-Mode but my laptop remained with that very same grey screen as you pictured above. I know that it takes longer to load, but I had the laptop on for a couple hours and nothing popped up. Should I have just left it on over-night while it was loading?

    Ehm, I don't know... I don't know what Filevault2 is. I'm sorry.
     
  4. Dalton63841 macrumors 65816

    Dalton63841

    Joined:
    Nov 27, 2010
    Location:
    SEMO, USA
    #4
    Can you boot into Single User Mode? (Command + S) If you can, it should arrive at a CLI prompt. Type:

    Code:
    /sbin/fsck -y
    /sbin/mount -wu /
    reboot
     
  5. Condork19 thread starter macrumors newbie

    Joined:
    Jun 18, 2013
    #5
    No, it just goes to verbose mode. I can't type anything, I just see qhite writing on the black screen.
     
  6. Dalton63841 macrumors 65816

    Dalton63841

    Joined:
    Nov 27, 2010
    Location:
    SEMO, USA
    #6
    The white text on a black screen is single user mode(assuming you used Cmd+S to get there). It should arrive at a prompt where you can type. Then put in the commands from my previous post. That is called a CLI(Command Line Interface), as opposed to a GUI(Graphic User Interface). Those commands do a filesystem check(and repair if necessary), mount the filesystem cleanly, and then reboot, so that the filesystem unmounts cleanly so if that's the only issue it should reboot into a working system.
     
  7. Condork19 thread starter macrumors newbie

    Joined:
    Jun 18, 2013
    #7
    No, there is nothing that comes up that allows me to type. I've pressed cmd+s before I turned the laptop on and after but I'm never able to type in anything.
     
  8. majkom macrumors 65816

    Joined:
    May 3, 2011
    #8
    Maybe disk is dead (I had similar problem with macbook air revA) - but AFAIR i was able to format disk and instal os x (but after max few months, same thing happened again) - try to boot from usb drive, does that work?
     
  9. skofgar macrumors newbie

    Joined:
    Jun 18, 2013
    #9
    Maybe you could try the Target Disk Mode

    Oh - sorry to hear that nothing worked so far…

    Do you have another computer available?

    If yes:
    You might be able to try to retrieve/rescue data of your computer by using the Target Disk Mode (Depending on your MacBook Pro it would be via Thunderbolt or Firewire)

    • when booting press 'T' before the Apple-Logo shows up
    • e.g. a firewire symbol should appear instead of the Apple-logo
    • connect the mac via Firewire/Thunderbolt to another computer
    • your mac should show up like an external hard-drive

    http://en.wikipedia.org/wiki/Target_Disk_Mode


    About FileVault 2

    *FileVault 2 is an hard-drive encryption technology developed to protect sensitive information. It encrypts the entire hard-drive. Disk utility can only repair such hard drives / partitions if it knows the password to decrypt the hard drive. But it doesn't look like that this is the case with your Mac.
     

Share This Page