Mac switcher - frustrated in Dreamweaver and Fireworks

Discussion in 'Web Design and Development' started by northerner, Jan 2, 2011.

  1. northerner macrumors newbie

    Oct 31, 2007
    I know DW & FW aren't Apple apps, but I hope someone can hep me with this...

    I recently switched to working entirely on a mac. Lovely... BUT I have a frustration with a couple of apps - Fireworks and Dreamweaver, both Macromedia.

    On a PC, when these apps are fired up, they fill the desktop and give a grey blank background within them for me to start opening files etc. On the mac, any underlying app is visible through the 'blank' spaces not occupied by the app at the front - and its so distracting! It's very fiddly to try to 'hide' everything except the app I'm working in - is there an easy way to do this?

  2. TreborM macrumors member

    Jun 26, 2010
    Try "Hide Others" command

    Most (all?) apps let you hide all other windows by pressing:
    Alt+Command+H ("Hide Others")

    Is this what you wanted?

  3. northerner thread starter macrumors newbie

    Oct 31, 2007

    Thanks for that tip Trebor, but it doesn't quite do it for me.
    In fact, it doesn't work at all! Not with FW or DW - so I guess this feature is somehow missing form the Macromedia software.
    I can see that it works well enough with Apple apps - a nice trick, so thanks for that.

    Even when I clear away all underlying apps, this then leaves the desktop visible through all those unoccupied bits of space. Slightly less distracting - but not much!
    I really don't get it. On the mac, these apps seem to be an array of floating panes and panels, with whatever is underneath them visible through any gaps between the panes. On the pc, I have a nice, complete container, with a hard edge to it, which keeps everything held together. Maximise that container, and I see only that app. This doesn't seem possible on a mac.

    Am I just a bad, PC-washed computer user?!
  4. TreborM macrumors member

    Jun 26, 2010
    I haven't used Macromedia applications on a Mac.
    I am no Mac expert either...

    From you description it sounds to me that those apps have GIMP style interface, it seem to be simply different policy/design of the user interface ...

    Other may chime in with better solutions but the only thing I can suggest is to enable Spaces (which btw is great feature to have anyway), change the desktop background to something toned (all Spaces share the same wall) and bind both apps to two different spaces (you can do this via Preferences)

    Hope this helps,
  5. zlinuk macrumors member

    Jul 8, 2008
    under the "window" menu, select "use application frame", this will only work for fireworks however as Adobe in their wisdom decided to omit this piece of basic functionality from Dreamweaver.
  6. besler3035 macrumors 6502a

    Oct 29, 2004
    Grand Rapids, MI
    If you're still using the Macromedia versions of these programs, you're out of luck. I believe they added the "application frame" option long after Adobe acquired it...with CS4.
  7. chrono1081 macrumors 604


    Jan 26, 2008
    Isla Nublar
    Most adobe apps do the "floating window" thing on Mac. I don't have dreamweaver or flash installed anymore but in photoshop I I used to just drag the main window I'm working on to full size to avoid hitting the in between spaces and moving to the desktop.

    Now that I've been using macs for almost three years I now prefer the windowed thing (but I also have dual monitors which makes it easier). I generally drag the toolbars into the second monitor and keep the main workspace in the first.
  8. northerner thread starter macrumors newbie

    Oct 31, 2007

    Thanks for your help guys. I am using Macromedia's version of the sware do I guess there's nothign much I can do about it. Good to know I'm not doing anything 'wrong'. As a switcher there are lots of new things to get my head around :confused:
    Thanks for being here.

Share This Page