Mac taking 20+ mins to start up

Discussion in 'MacBook Pro' started by Dale-T-, Dec 6, 2010.

  1. Dale-T- macrumors newbie

    Joined:
    Dec 6, 2010
    #1
    Basically, for some reason my mac takes up to 20 + minutes to start up for me to be able to log into my user account, during start up I also get this funny screen shown in the picture which last for a few minutes.

    Is this a sign that my hard drive needs replacing or a sign of something else. This screen also appeared before I replaced my screen after the backlight went on it. I've also repaired my hard drive using the disk utility on the installation disc and it does the same, taking over 20 mins to loads. Any help is appreciated thanks.
     

    Attached Files:

  2. millerb7 macrumors 6502a

    Joined:
    Jun 9, 2010
    #2
    From the screen shot, that looks like the MBP with the 8600m GT graphics card? Is that right?

    If so, I'd head to apple and have them check that for you... that seems like it would be covered under the class action suit against NVidia, in which case apple is replacing them up to 4 years out from computer purchase date.

    Otherwise... bad logic board maybe?
     
  3. Dale-T- thread starter macrumors newbie

    Joined:
    Dec 6, 2010
    #3
    The graphics card is a ATI Radeon X1600.

    Maybe it is the logicboard, I have had the laptop quite a while now.
     
  4. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #4
    Most likely it is. Graphics artifacts like that could indicate this.
     

Share This Page