Mac to UNIX FTP Issue

Discussion in 'macOS' started by paulcu, Oct 7, 2009.

  1. paulcu macrumors newbie

    Joined:
    Dec 6, 2006
    #1
    Two months ago I switched web hosting providers/services from a Linux server to a UNIX server. For the most part the functionality is fine but the ability to upload files using any FTP client is near impossible. We've tried Fetch (4.x and 5.x) Filezilla, Cyberduck, Dreamweaver, and an old copy of GoLive but it takes 6 minutes or more to upload a 230byte file!. The upload is relatively fast but it hangs up on the exiting handshake, or drops the connection and has to reconnect.

    We spoke with Fetch and tested both copies on their UNIX server---no problem. We've tried our other clients on other UNIX, Windows, and Linux servers---no problem. We've had the web host and our service provider look at DNS blocks, etc. and all seems to be fine. Pings and trace routes seem fine.

    The web host company indicated that they believed that it was an issue with their server but eventually threw up their hands and said that they couldn't figure it out (not Mac friendly I suspect). My questions is two fold:

    1) Can anyone give me an idea what IS the problem?

    2) Can anyone recommend a good 'Mac-friendly' web hosting service that doesn't have issues with Mac's, will allow installation of a variety of CMS, eCommerce solutions, and of course seamless FTP access with variety of clients.

    frustrated with ineptitude
     
  2. Winni macrumors 68030

    Winni

    Joined:
    Oct 15, 2008
    Location:
    Germany.
    #2
    Here's my provider: http://www.hosteurope.de

    But they're in Germany and their website only speaks German. Their service is excellent, though, and their support staff is very competent and know their business. And their (Linux-based) servers don't have any FTP issues when I upload with CyberDuck. ;)

    Anyway. Have you tried switching between "active" and "passive" transfer modes in your FTP client? It can make a huge difference.
     
  3. paulcu thread starter macrumors newbie

    Joined:
    Dec 6, 2006
    #3
    Winni, maybe I'll have to brush up on my German ;)

    We've tried the active/passive thing along with switching between FTP and SFTP. We've also tried using the IP address instead of the FTP URL. Fetch 4.x seems to be the most stable, the others less so with Dreamweaver and GoLive unable to maintain a connection. What's interesting is that we have customers on a Windows server with the same web host and we don't have any of these issues. We've also reset permissions on the server side and tried using the web hosts browser based FTP interface---with no luck. We've tried it from other computers in the office as well, and checked our router, firewall, etc.
     
  4. BobZune macrumors 6502a

    Joined:
    Oct 26, 2007
    Location:
    USA
    #4
    You can try the command line ftp with debug on and see if there are any 'interesting' differences between your provider and other servers. ("man ftp" on the terminal, no quotes).
     

Share This Page