Mac Trackpad/Touchpad not working (at all!) under XP sp3 (bootcamp)

Discussion in 'MacBook' started by Duim, Feb 27, 2010.

  1. Duim macrumors newbie

    Feb 27, 2010
    I've installed XP sp3 on my macbook, works great....except the trackpad.

    Most common problem with the trackpad (in other threads) is slugish response or whatever, but not here: the device just does not work at all.

    These are the symptoms:
    - no life in the touchpad device
    - device manager shows an exclamation mark on the touchpad and says it wants me to update the driver (after enabling). This does not help a bit,I tried all the decision paths after right clicking it, include downloading some driver from the internet and pointing the operating system to this driver: no avail.
    - asseccories->system tools->system information: signed drivers does not even report something looking like a track or touchpad.
    - updating to bootcamp 2.2 didn't bring anything.
    - often threads (mostly about the trackpad being slugish) endup pointing to the 1.1 update ( , but something not available cannot be doesn't work
    -under the apple operating system it works great.

    The thing that bugs me the most: no thread is reporting anything about this problem, this makes me think it's a REAL problem and not just some checkmark I forgot.

    Probably nothing to do with this, but my motherboard was replaced a few months ago (under warrenty), can they have forgotten to hook something up there? I never tried XP before that repair on this machine.
  2. snowboyken macrumors newbie

    Jun 29, 2010
    I got same problem on my Macbook Pro 2009 - June , My trackpad running on windows xp doesn't have any problem at the begining, but it suddently not work after 1 year, it keeps "!" of the device status of the Device Manager, when I try to install a new driver, no change and leeps prompt to found and install a new device and keep asking me the driver location. Anyone have this problem please raise out.

Share This Page