Mac version of Samsung 840 evo pro firmware update not doing anything

Discussion in 'Mac Accessories' started by fhall1, Jan 13, 2015.

  1. fhall1 macrumors 68040

    fhall1

    Joined:
    Dec 18, 2007
    Location:
    (Central) NY State of mind
    #1
    I have a Samsung 1TB 840 evo pro SSD that indeed exhibits the issue with slow copies of older data. It is the boot (and only) drive in my 2012 Mac Mini.

    Now that I have some free time, I cloned the drive this morning to an external drive using CCC.

    I downloaded the Samsung firmware updater for Mac and burned the ISO to a CD using an external USB DVD drive on the Mini. I restarted the Mini holding down the ALT (Option) key and one of the choices presented was to boot to "Windows" with a CD icon.

    I chose that option and the CD drive read for a few seconds (the updater is only 3MB), I get a flashing white cursor on the top left of a black screen. It's been that way for 45 minutes now.

    In the Samsung documentation - there's a troubleshooting question that says "Why does the Samsung SSD Firmware Update application take so long to open?" with the answer "The Firmware Update application tries to detect all disks connected to the system upon launch. This may require a few minutes, depending on the number of disks connected to the system and the hardware platform."

    My questions are - has anyone used this boot software to update and is 45 minutes long enough to wait that it's obviously not going to work for me?

    I only have the SSD boot drive and a firewire external (time machine) drive connected to the system.....it shouldn't be taking this long to find the Samsung drive in my opinion. Thoughts???
     
  2. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #2
    There's no "Evo Pro." You either have an Evo or a Pro. Are you sure you have the proper firmware update?
     
  3. fhall1, Jan 13, 2015
    Last edited: Jan 13, 2015

    fhall1 thread starter macrumors 68040

    fhall1

    Joined:
    Dec 18, 2007
    Location:
    (Central) NY State of mind
    #3
    Mis-typed, I have an 840 EVO.....no pro. Yep...I have the right firmware downloaded.

    As an addendum...I went back to the Samsung site and downloaded the DOS version (for Mac/Linux it says) of the "Performance Restoration" package. This supposedly updates firmware and corrects the slow read of old data issue.

    I burned a CD with that ISO, and booted from it and the DOS-like screen came right up - it has supposedly updated the firmware and is on step 2 (of 2) of performance restoration.

    It's been in step 2 for almost 2 hours now, but I do have 800G of data on the 1TB drive, so it may take a while - and the progress "dots" are slowly incrementing.

    EDIT: Finally completed in a little over 5 hours....restarted and OS X came up with no issues.
     
  4. gamabr macrumors newbie

    Joined:
    Jan 14, 2015
    #4
    Upgrade firmware samsung 840 ssd - external drive

    Hi. I had the same problem as you and it seems to be resolved now.

    I have a 1Tb 840 SSD Samsung and now I am using it as a external drive connected by a Seagate Thumderbold adapter. I use both IOS and Boot Camp.

    I will explain what I did in order to help you.

    1) First, I tried to upgrade the firmware of the SSD by downloading the Samsung SSD 840 EVO Performance Restoration Software .iso file and burning into a CD (http://blog.conradchavez.com/2014/1...vo-ssd-performance-restoration-tool-on-a-mac/).

    The problem: the cd created is not bootable. It didn't work.

    2) Then I renamed the iso file to “Samsung_Performance_Restoration.dmg” (as in http://blog.conradchavez.com/2014/1...vo-ssd-performance-restoration-tool-on-a-mac/).
    It was able to boot but the SSD was not recognized (external drive).

    3) Then I formated the SSD in Disk Utility to exfat (the driver was shown as Samsung 840 EV0), then I tried to upgrade the firmware in Boot Camp.
    In Boot Camp I formated the SSD as NTFS, and download the Samsung SSD 840 EVO Performance Restoration Software for Windows.
    The program was installed and I restarted the computer.
    Then the program was able to recognize the SSD and updated the firmware.

    That's the only way I succeeded. I hope to help you. :)
     

    Attached Files:

  5. Xeridionix macrumors regular

    Joined:
    Jan 6, 2015
    #5
    The Samsung 840 EVO Performance Restoration Tool isn't able to read HFS+ formatted volumes, only Windows formats (NTFS and FAT32). Your best bet once the firmware has been updated successfully to ensure that the performance of your drive returns to normal would be to erase the startup disk and then restore the clone of your installation back to the disk, which will re-write everything to the SSD. Once that's done it should run good as new.
     

Share This Page