Mac Won't Boot After Security Update or Failed Java Update

Discussion in 'Mac Basics and Help' started by LeperKahn, Jun 17, 2009.

  1. LeperKahn macrumors newbie

    Joined:
    Jun 17, 2009
    #1
    Hello!
    I'm running an intel iMac Core 2 Duo from a few months back. I installed the most recent security update for Mac OS X Leopard and after the reboot the computer worked fine for 2 more boots. (Note: during these boots I noticed that often my computer would get the spinning rainbow wheel for a long time before it went away. It happened at apparently no prompting.) After those I installed the game City of Heroes on my macintosh and then attempted to install the new safari and Java update (I haven't updated in a while.) I was told the Java update and safari update failed to install. I rebooted to try again and attempted to install again. Both failed.

    I gave up and started playing CoH. About 2 hours after playing my game froze. I was running ventrillo at the same time and was able to talk on that. After many failed tries to use command + option + escape I decided to hold down the power button to reboot my computer. The first attempt yielded a solid blue screen. The second attempt the computer started fully. Stupidly I assumed the problem was fixed and didn't backup software and files.

    I tried to run City of Heroes again and the app would not even show up in dock. It simply would not run. All other apps seemed to work fine. I rebooted again and this time I got another blue screen. Again, but this time I got the grey screen with the apple symbol and the spinning wheel. I've never gotten past this screen again.

    I have boot camp so I tried to boot into windows. Windows booting was successful. After that I rebooted and attempted to use the advice from this thread for help: http://forums.macrumors.com/showthread.php?t=322670 I tried the single user mode fix first. I got the message:

    /dev/rdisk0s2
    Root file system
    Checking Journaled HFS Plus volume
    Checking Extents Overflow file.
    Checking Catalog file.
    Incorrect block count for file temp3271201
    (it should be 8 instead of 0)
    Keys out of order
    (4, 966)
    Rebuilding Catalog B-Tree.
    The volume Ben's Computer could not be repaired.

    FILE SYSTEM WAS MODIFIED

    After that I tried to reset PRAM. Still the grey apple with the spinning wheel. I tried the single user start up again. Again failed.

    After that I tried booting into safe mode. Using these steps: http://support.apple.com/kb/HT1455 Unfortunately, NONE of these ways would let me boot into safe mode. Both left me at the same grey apple icon and spinning grey wheel.

    I would appreciate help SO much. Even if the only fix is to get a new computer any advice would help me. If I need to somehow reformat or such then if anyone might know how I could backup my settings and applications with this impediment.
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    Boot from install disk and try to repair disk, repair permissions.

    If that doesn't work then reinstall. Doesn't take long for OSX.

    Otherwise contact apple care. They'll probably tell you to reinstall first.
     
  3. Kobra macrumors regular

    Kobra

    Joined:
    Jun 17, 2009
    Location:
    Sweden
    #3
    The EXACT same thing happened to me last night, I didn't either get back in to the OS. In the end I gave up and installed my new HDD and made a fresh install. I REALLY hope I'll never experience it again...
     
  4. wrbush31 macrumors newbie

    Joined:
    Jun 24, 2009

Share This Page