Mac won't mount external HDD since 10.8.4 update?

Discussion in 'OS X Mountain Lion (10.8)' started by sumshiftyguy, Jul 26, 2013.

  1. sumshiftyguy macrumors newbie

    Jul 26, 2013
    Hi All

    I'm fairly new to Mac (3mths) so still finding my feet...hopefully someone is able to help me here!

    MBP 2.7Ghz running (now) Os 10.8.4
    WD HD5000D032-000 (the old drive)
    3TB WD Red (the new drive)

    Solutions tried to the problem (described in detail below):
    - restart Mac
    - restart eHDD
    - different USB and power cables for eHH
    - different Mac(mini)
    - removed eHDD from stock housing and used SATA docking station
    - bought new HDD and used with SATA docking station

    Now to the detail of my problems:
    I've had a WD 500GB external HDD for about 8yrs. Formatted FAT32. Used with PC/Win laptop no issues.

    Switched to Mac and no issues at all. However after a recent trip to Japan I plugged in the HDD to back up all the photos and vids I'd taken (I took my Mac with me to download off the the various SD cards,etc), the HDD plugged in and booted fine as normal and file transfer was initiated. The folder was large (don't recall how much but a few GB at least). Everything seemed to be progressing fine so left both Mac and HDD plugged in and carried on watching tv. Noticed a few mins later that an error message had popped up saying disk could not be found (or something similar).

    HDD was no longer visible. Therefore I unplugged and reconnected and.... nothing. I can see the HDD in Disk Utility but it's not mounted. Options to verify/repair disk are greyed out. At this point I tried using different cables and USB ports and still no improvement. I've also tried restarting both Mac and HDD.

    A few hours of reading forum posts suggested the HDD housing may be the culprit as it was quite old and prone to failing. As I'd tried all else, I went out and bought a SATA docking station and removed the HDD from its stock housing. This yielded the same results - I can see the HDD clearly in Disk utility but can't mount or verify/repair.

    I then tried plugging into mate's Macmini running and older Osx and this time, the verify/repair options are available. Tried them and result was disk could not be repaired by Disk Utility. I still couldn't mount the drive and access any files though.

    I had been planning on setting up a NAS anyway so ordered a new 3TB eHDD (WD Red) which arrived yesterday. I plugged it in using the docking station ni order to format it to FAT32 so that I could at least download my data from my Mac (and then subsequently look to recover all the data from the old eHDD) but the option 'MS-DOS File System' isn't available in the drop down in Disk Utility/Erase.

    All the steup guides on formatting HDDs using Mac suggest that I should have this option in order to format as FAT32. All I see are 3 types of 'MS-DOS (extended)' and 'exFAT'.

    The twist:
    All this time I just assumed that it was the hardware acting up but the fact that the new HDD isn't recognised properly either made me wonder. I remember updating the OS to 10.8.4 whilst I was away in Japan and connected to wifi. I presumed that any update that was pushed down to me was good to go - could I be wrong??

    I've also noticed that my wifi sometimes takes a while to connect / disconnects by itself and skype repeatedly drops calls since the update. From more reading around, I see that these are some issues people have experienced since updating to 10.8.4.

    So could my HDD issues be being caused by 10.8. 4 as well?!

    I'm out of ideas so now wondering whether I should try and roll back the 10.8.4 update but I've not idea whether this is safe/easy to do, etc...

    Any help would be VERY much appreciated!!

    Thanks in advance!

  2. Weaselboy Moderator


    Staff Member

    Jan 23, 2005
    Based on your description, the old hard drive is bad. Time for the trash can with that one. OS X 10.8.4 would not cause this.

    If there is data on the old drive you need to recover you might try some after market tools like Disk Warrior. But if the drive will not even mount, you may be sunk.

    It sounds like your new drive is working fine, but you are misunderstanding the Disk Utility format options.

    Look at my screenshot below. That MS-DOS (FAT) option you see there is FAT32 if that is what you are after. I would choose the ExFAT option though since it is not subject the the FAT32 4GB file size limitation. ExFAT will be read/writeable on both Macs and PCs.


Share This Page