Mac won't print wirelessly to PC usb printer

Discussion in 'Mac OS X Server, Xserve, and Networking' started by svsnyder, Jan 9, 2010.

  1. svsnyder macrumors newbie

    Jan 9, 2010
    Hope this is the right forum. Please redirect me if it's not.

    New Macbook running OSX Snow Leopard. Connects easily via my wireless network, communicates with the PC and it's two external HD's. Only problem is printing. in the system prefs/print & fax window I've tried adding printers via the "default" tab (obviously nothing there). Under "IP" I've added it under "Line printer daemon - LPD" with a valid address and name where after "gathering printer info" it lists it as a "generic postscript printer" - I change it to Canon MP600 driver and click "add" and a window drops down for a half second saying "determining installable options..." then nothing - won't let me add it. Same thing under "Internet Printing Protocol - IPP." Finally, under the "windows" tab, it allows me to add it successfully but nothing happens when I print (the queue says it printed but it never completes). I can't communicate with it via the "Options & Supplies" either - say's "gathering info," then "No info available." I've tried using the OSX canon driver, I've installed both the latest canon driver for it and the "cups" driver - no luck.

    I have read about some issues specifically with the Canon drivers and wireless printing with Snow Leopard. There's gotta be a work around that works (tried several). Any info would be appreciated. I'm new to mac too, so please be gentle...
  2. svsnyder thread starter macrumors newbie

    Jan 9, 2010
    Sorry - should have specified:

    Macbook connected wirelessly (duh)
    PC with Windows XP SP3 also connected wirelessly
    Canon MP600 connected via USB to aforementioned PC
    Linksys router

Share This Page