Mac working like command key is constantly pressed (problem solved, thanks)

Discussion in 'Mac Basics and Help' started by Hitomi, Oct 21, 2009.

  1. Hitomi macrumors newbie

    Joined:
    Oct 21, 2009
    #1
    Hello,

    Something strange happened yesterday to my computer, it had a failure with a software and suddently the keyboard didn´t work as it has to be.

    I couldn´t write anything and it was like command key is pressed all the time because it worked like a key combination. For example, when I press the "w" letter it closes windows, I cant´t even write a web address neither my pass to fix something in the settings

    ¿Anybody knows something about that?

    Thanks in advance for your help
     
  2. iBlue macrumors Core

    iBlue

    Joined:
    Mar 17, 2005
    Location:
    London, England
    #2
    Have you tried unplugging and cleaning the keyboard? Maybe giving it a shot of compressed air or something? Have you rebooted? I'm sure these are pretty obvious things and I'm sorry to have to ask but sometimes people really don't try the obvious things first.

    I'm not sure what you mean by "it had a failure with a software".
     
  3. Hitomi thread starter macrumors newbie

    Joined:
    Oct 21, 2009
    #3
    Don´t worry to ask, maybe I could have forgotten something but I already unplugged the keyboard, cleaned it and reboot, I even did a system recovery and it didn´t work at all, it works funny everytime.

    What exactly happened? I was working with photoshop and it started to work very slow, then, finder restarted and it started to work funny since that moment. I don´t know if I pressed some keys that made something work funny but when I pressed the the F5 key after this, voice over started instead to change desktop (is the function I assigned to this key).

    So I don´t know what I can do now...
     
  4. pdubak macrumors member

    Joined:
    Oct 20, 2009
    #4
    Try this in order:

    Check system preferences>Universal access and check if "Sticky Keys" are enabled. If so, disable them.

    Restart in safe boot (hold shift key at boot). You may need to do this anyways if you find sticky keys are enabled and you can't type in your password.

    When in safe boot, go to System Preferences>Accounts>Login items. Chances are your new software is hozing up something. Disable each item one by one until you figure out what it is. Chances are it's what you last installed.

    Reset the PRAM (Hold Apple+Option+P+R at boot up) you can release the keys when you hear it chime again.

    Rule out hardware by trying another USB keyboard and seeing if it still occurs. If it doesn't, your keyboard is bad/has a stuck key. Replace your keyboard if so.

    Those are just a few. I did a quick Google and found it's actually quite common and there are a lot of fixes to try. Head there next.
     
  5. Hitomi thread starter macrumors newbie

    Joined:
    Oct 21, 2009
    #5
    Thanks for your help, I checked about stiky keys and it wasn´t enabled but I´ll try to restart in safe mode because I didn´t tried that.

    I´ve unplugged the keyboard and tried to write with the keypad but it works the same as if I use the keyboard, like the command is pressed everytime.

    It´s really strange, I couldn´t find more about it at google :/
     
  6. Hitomi thread starter macrumors newbie

    Joined:
    Oct 21, 2009
    #7
    Thanks a lot, I´ve been searching but I didn´t reach such results, maybe I wasn´t so specific.

    Anyway I´ll try to reset PRAM but as I said, no stiky keys were enabled.

    Thanks a lot everyone for your help

    Edit: Solved, I just removed the bateries one more time and I left it alone for a while, then it begun to work perfectly again. Maybe when I tried it first I didn´t wait enought or maybe I didnt restarted with the bateries out of the keyboard, I don´t remember what I did wrong, anyway thanks for your help, it just ended like a minor incidence
     

Share This Page