Macbook 12" wakes regularly

Discussion in 'MacBook' started by SidBoggle, May 15, 2015.

  1. SidBoggle macrumors regular

    Joined:
    Sep 30, 2007
    Location:
    Bucks, UK
    #1
    I wonder, is anyone else experiencing regular wakeups with the new Macbook? Every couple of hours I see:

    wake reason: ARPT (Network)
    wake reason: wake on TCP Data

    I have disabled "Wake for WiFi Network Access" and Power Nap, reset SMC etc and still regularly see these wakes in my syslog.

    You can do a search for "wake reason" in the console app or run this command in terminal to see when it wakes up:

    syslog | grep -i "wake reason"

    Last night I disabled Wi-Fi overnight and it slept without any wakeups so it is definitely related to network access. I had a similar problem on my iMac after upgrading to Yosemite and this was fixed in v 10.10.3 so I wonder if there is a problem with the new Macbook on this OS version.

    I set up the Macbook from scratch as a new device so it should be a fairly default setup.
     

    Attached Files:

  2. Cvx5832 macrumors regular

    Joined:
    Nov 2, 2014
    #2
    I also have those options deselected, and I believe these are features of the OS itself, specific to the MacBook and it's intended use - portability. Just some examples I've noticed from a recent trip:

    When tethered to your iPhone the connection is not severed when the computer sleeps (closed). While some will not appreciate whatever load impact that has, it was very convenient just opening it up and being instantly connected. This is even faster than that momentary hesitation when connected to WiFi.

    I stayed at a Hilton over the last week and when first connected to their WiFi you get a pop-up that has the "pay" window. You choose what package you want or log in with your membership number to get it for free. This window was already popped open every time I opened my computer after coming home from work each day, with or without Safari running.
     
  3. mattopotamus macrumors G5

    mattopotamus

    Joined:
    Jun 12, 2012
    #3
    There have been a few threads/people mentioning this issue. I personally am not having issues, but hopefully people running the beta 10.10.4 can confirm if it is fixed.
     
  4. ajpuciat macrumors member

    Joined:
    Sep 10, 2015
    #4
    Definitely not fixed. The issues with waking seem to depend on what network you are connected to. I have been in the habit of turing off wifi manually before sleeping. Seems to save me a TON of battery life. This screenshot is what happens when I leave wifi on prior to shutting the lid.

    Of note - I have Power Nap and Wake on Network Data disabled.
     

    Attached Files:

  5. polteris macrumors newbie

    Joined:
    Jun 11, 2016
    #5
    I also disable wi-fi because of that broblem. Save a looooot of battery!! Hope for a fix!!
     
  6. ajpuciat macrumors member

    Joined:
    Sep 10, 2015
    #6
    Anyone know of a script to automatically disable wifi on lid close and re-enable on open?
     
  7. tom123 macrumors regular

    tom123

    Joined:
    Apr 9, 2006
    Location:
    Ohio
    #7
    Good idea!! Bump - anyone?
     

Share This Page