Macbook 13" Airport Card Replacement HELP

Discussion in 'MacBook' started by liberator32, Jul 31, 2011.

  1. liberator32 macrumors newbie

    Joined:
    Jul 8, 2007
    #1
    Macbook, 2.0GH, running OSX 10.4.11

    This was purchased in June of 2006. My airport signal is very low lately and I have A/B'd it against other macbooks on the same networks etc. I am pretty sure it's not a software issue (even upgraded my OS to Leopard to see if it improved and it did not. Went back to 10.4 because of the front row features.)

    Anyways, the part number for the airport card I need is "6613890 airport extreme card."

    What's my best move here in terms of getting better signal? Do other airport cards work in this one (mine has the two antennae). Do I go with a USB adapter instead? I am not afraid to do the mechanical side of the install just don't know which part to get to OPTIMIZE my current machine. Yes, I am aware that it's an antique!

    Sorry for anything I left out. i appreciate your help.
     
  2. unixperience macrumors regular

    Joined:
    Jul 21, 2010
    #2
    I don't know of too many airport cards with only two antennas. I'm not an expert for sure, but I'm pretty sure the majority of the them came with 3 (the new pros come with 4)

    If you could compare signal with someone who has EXACTLY the same computer (not just any macbook) that might be helpful too. But i wouldn't try to upgrade cards, if it comes to that. I would just get a new card, same model and install that. But I'm not sure that would help even. Like i said try to find a similar computer, that could tell you what to expect with your computer.
     
  3. liberator32 thread starter macrumors newbie

    Joined:
    Jul 8, 2007
    #3
    Thanks for the reply.

    I took the computer apart and it is definitely a two wire (google the part number I provided and you'll see).

    I did A/B it against the exact same machine on several networks. Mine still sucks in comparison.
     
  4. bluedogz macrumors newbie

    Joined:
    Aug 21, 2010
    Location:
    Havre de Grace, MD
    #4
    I had the same problem with an '08 Blackbook... new AirPort card, sorted.
     

Share This Page