Macbook 2009 typing blanks

Discussion in 'MacBook' started by alokm, Apr 1, 2014.

  1. alokm macrumors newbie

    Joined:
    Jan 28, 2013
    #1
    Hi,

    I have a Macbook A1342 (2009), which has been upgraded to OSX 10.9.2. It has developed a problem with the keyboard and is typing blank spaces for some keys, for some it types nothing at all and there are only three keys for which it types (0, æ and ')

    The external USB keyboard works perfectly, which I would think would rule out a logic board problem.

    Could it be a connector problem or :confused:

    regards
    Alok
     
  2. alokm thread starter macrumors newbie

    Joined:
    Jan 28, 2013
    #2
    Keyboard identifier error logs

    Hello friends,

    If someone could help me decryptify these installer logs... I would be very thankful, there is a reference to changing Keyboard identifier which I could not understand... :eek:

    Apr 1 05:30:15 localhost opendirectoryd[101]: opendirectoryd (build 339.90.1) launched - installer mode
    Apr 1 05:30:15 localhost opendirectoryd[101]: Logging level limit changed to 'notice'
    Apr 1 05:30:16 localhost opendirectoryd[101]: Initialize trigger support
    Apr 1 05:30:16 localhost opendirectoryd[101]: created endpoint for mach service 'com.apple.private.opendirectoryd.rpc'
    Apr 1 05:30:16 localhost opendirectoryd[101]: set default handler for RPC 'reset_cache'
    Apr 1 05:30:16 localhost opendirectoryd[101]: set default handler for RPC 'reset_statistics'
    Apr 1 05:30:16 localhost opendirectoryd[101]: set default handler for RPC 'show'
    Apr 1 05:30:16 localhost opendirectoryd[101]: starting endpoint for service 'com.apple.private.opendirectoryd.rpc'
    Apr 1 05:30:16 localhost opendirectoryd[101]: no dynamic data found at '/System/Library/OpenDirectory/DynamicData/Configure.plist'
    Apr 1 05:30:16 localhost opendirectoryd[101]: Registered node with name '/Configure' as hidden
    Apr 1 05:30:16 localhost opendirectoryd[101]: no dynamic data found at '/System/Library/OpenDirectory/DynamicData/Local.plist'
    Apr 1 05:30:16 localhost opendirectoryd[101]: Registered node with name '/Local' as hidden
    Apr 1 05:30:27 localhost Unknown[347]: kern.boottime: { sec = 1396355400, usec = 0 } Tue Apr 1 05:30:00 2014
    Apr 1 05:30:28 localhost Unknown[358]: Launching the Language Chooser for an OS Install
    Apr 1 05:30:40 localhost Language Chooser[359]: Waiting for prepaired devices to appear
    Apr 1 05:30:44 localhost configd[114]: subnet_route_if_index: can't get interface name
    Apr 1 05:30:53 localhost Language Chooser[359]: Prepaired wait done.
    Apr 1 05:30:53 localhost Unknown[360]: Keyboard Layouts: duplicate keyboard layout identifier -16899.
    Apr 1 05:30:53 localhost Unknown[360]: Keyboard Layouts: keyboard layout identifier -16899 has been replaced with -28673.
    Apr 1 05:30:53 localhost Unknown[360]: Keyboard Layouts: duplicate keyboard layout identifier -16900.
    Apr 1 05:30:53 localhost Unknown[360]: Keyboard Layouts: keyboard layout identifier -16900 has been replaced with -28674.
    Apr 1 05:30:53 localhost Language Chooser[359]: Set keyboard to id: -21
    Apr 1 05:30:54 localhost Language Chooser[359]: Found primary language hint "en"
    Apr 1 05:30:54 localhost Language Chooser[359]: Could not write to /var/log/CDIS.custom
    Apr 1 05:30:54 localhost Unknown[360]: Setting boot completed.
    Apr 1 05:30:56 localhost Language Chooser[359]: Launching the Springboard using language code "en"
    Apr 1 05:30:57 localhost OSIESpringboard[379]: LSExceptions [0x7ff5cb410130] loaded
    Apr 1 05:30:57 localhost OSIESpringboard[379]: Can not connect to /var/run/systemkeychaincheck.socket: No such file or directory
    Apr 1 05:30:57 localhost OSIESpringboard[379]: Failed to unlock login keychain.
    Apr 1 05:30:57 localhost Unknown[360]: 2014-04-01 05:30:57.611 OS X Utilities[379:303] *** WARNING: -[NSImage compositeToPoint:fromRect:eek:peration:] is deprecated in MacOSX 10.8 and later. Please use -[NSImage drawAtPoint:fromRect:eek:peration:fraction:] instead.
    Apr 1 05:30:59 localhost Unknown[360]: Keyboard Layouts: duplicate keyboard layout identifier -16899.
    Apr 1 05:30:59 localhost Unknown[360]: Keyboard Layouts: keyboard layout identifier -16899 has been replaced with -28673.
    Apr 1 05:30:59 localhost Unknown[360]: Keyboard Layouts: duplicate keyboard layout identifier -16900.
    Apr 1 05:30:59 localhost Unknown[360]: Keyboard Layouts: keyboard layout identifier -16900 has been replaced with -28674.
    Apr 1 05:31:08 localhost OSIESpringboard[379]: LSExceptions [0x7ff5cb410130] unloaded
    Apr 1 05:44:43 localhost configd[114]: subnet_route_if_index: can't get interface name
    Apr 1 05:46:58 localhost Unknown[360]: 2014-04-01 05:46 OS X Utilities[379] (CarbonCore.framework) FSEventStreamStart: ERROR: FSEvents_connect() => Unknown service name (1102)
    Apr 1 05:47:00 localhost OSIESpringboard[379]: Connection to sharingd became invalid
    Apr 1 05:47:00 localhost OSIESpringboard[379]: Connection to sharingd became invalid
    Apr 1 05:47:00 localhost Unknown[360]: 2014-04-01 05:47:00.509 OS X Utilities[379:495b] Metadata.framework [Error]: couldn't get the client port
    Apr 1 05:47:00 localhost OSIESpringboard[379]: Folder Manager is being asked to create a folder (docs) while running as uid 0
    Apr 1 05:47:04 localhost OSIESpringboard[379]: CoreServices logging is enabled,
    Apr 1 05:47:04 localhost OSIESpringboard[379]: SFL Favorites initialized.
    Apr 1 05:47:35 localhost Unknown[360]: 2014-04-01 05:47:35.238 OS X Utilities[379:303] !!! _NSLayoutTreeLineFragmentRectForGlyphAtIndex invalid glyph index 0


    Thank you for any help possible....
    regards
     
  3. alokm thread starter macrumors newbie

    Joined:
    Jan 28, 2013
    #3
    FINALLY I FOUND A SOLUTION...



    Posting this as a help for someone who might be stuck in the same situation...



    Somehow my keyboard mapping has got corrupted and since I could not find a direct way to edit the keymapping for Mac I used a superb software called KeyRemap4MacBook and it has remapped my key settings, over-riding the defaults in my Macbook and now I can happily work on my macbook. It seems that somehow there is a hardware error and my Left Shift key is not working but all the rest now work properly...:)
     

Share This Page