Macbook 2010 help

Discussion in 'MacBook' started by Noetics, Nov 7, 2014.

  1. Noetics macrumors member

    Noetics

    Joined:
    Nov 8, 2013
    #1
    Hello folks

    Yesterday I bought an old macbook from one of my partners friends, its in awesome condition and I am planning on putting 8GB of ram in and a 256GB Kingston SSD to give it some extra power.

    However, I hit my first hurdle when I tried to set it up as a new mac.

    When I boot up, it goes straight into recovery, and gives me four options.

    Restore your Mac from a Time Machine backup.
    Verify and repair connected drives using Disk Utility.
    Check your Internet connection or get help online using Safari.
    Install or reinstall OS X.

    I've tried the second option, erasing the hard drive completely, and then the fourth option of reinstalling OS X but it keeps prompting me for an apple id and password, and when i provide it with mine it gives an error message 'this item is temporarily unavailable'.

    Can anyone help? Do I need to return it to the previous owner and ask her to wipe it properly, or is there a work around where I can set this up for a new owner without going back to her?

    Cheers
    Jim :apple:
     
  2. Conv3rs macrumors newbie

    Joined:
    Nov 7, 2014
    #2
    Do you have the install disks. I find using install disks to remove and reinstall everything works when I reformat my macbook. Also what about physically taking out the hard drive and reformating using a hard drive reader (hard drive plugs into reader, reader plugs into usb of another computer, acts as removable hard drive). I've never encounted it asking for apple id and password. The mac might be locked as well because I know you can use "findmyiphone" app to lock macbooks now. All possible ideas I was just thinking of. Hope it helps.
     
  3. Noetics thread starter macrumors member

    Noetics

    Joined:
    Nov 8, 2013
    #4
    Managed to resolve this by using the snow leopard install disks - phew!

    Then I updated to OS to Yosemite, runs like a dream.

    Cheers
    Jim
     
  4. Jonathon71 Suspended

    Joined:
    Nov 23, 2014
    #5
    Simple

    Simply open another apple ID with another device or try your partner's or any other ID to open it. I had the same problem. First, I was worried too.
     

Share This Page