Macbook 9,2 (mid 2012) display issues. Logic Board?

Discussion in 'MacBook Pro' started by honeycombz, Jun 24, 2017.

  1. honeycombz, Jun 24, 2017
    Last edited: Jun 24, 2017

    honeycombz macrumors 6502

    honeycombz

    Joined:
    Jul 6, 2013
    #1
    Hey, got a used Macbook Pro 9,2 with an SSD in it. Really sweet laptop. However, on several occasions I am running into some display issues on boot up. Wondering if I have a lemon on my hands, what the problem might be, and what could be done about it as I really like this machine. As I said, the issue has been really intermittent. I ran the 3 min AHT and it found nothing.

    Screenshot 2017-06-24 17.47.03.png Screenshot 2017-06-24 17.47.30.png
     
  2. ApolloBoy macrumors 6502a

    ApolloBoy

    Joined:
    Apr 16, 2015
    Location:
    San Jose, CA
    #2
    Try reseating the LVDS cable perhaps? It's a large connector on the top right corner when you open it up; simply flip open the gold latch, pull it out horizontally and then back in and set the latch back down.
     
  3. honeycombz thread starter macrumors 6502

    honeycombz

    Joined:
    Jul 6, 2013
    #3
    Is there a step by step somewhere on this? Just want to see someone do this before I attempt.
     
  4. honeycombz thread starter macrumors 6502

    honeycombz

    Joined:
    Jul 6, 2013
    #4
    Could this have something to do with the occasional boot to black screen, then after a bit of wait you get the user login screen and everything seems fine? Seems to happen on a cold boot not restart. Is there some verbose way of booting up where I might be able to get more information what is going on?
     

Share This Page