Macbook Air 2012 Apps not seeing a connection on wake

Discussion in 'MacBook Air' started by jabingla2810, Aug 27, 2012.

  1. jabingla2810 macrumors 68020

    Joined:
    Oct 15, 2008
    #1
    My Macbook Air (2012) always has Safai, Mail, iTunes, Spotify, Tweetbot and iPhoto open.

    But EVERYTIME I lift the screen to wake the computer up I find Mail, iPhoto and Tweetbot all have issues.

    Mail says it is Offline, iPhoto’s sharing button says it has no connection, and Tweetbot stops automatically updating the stream

    It’s almost as if when the Macbook wakes up these apps instantly check for the internet, and when it doesn’t find a connection the apps go into an offline state.

    But if they were to check for an internet connection 2 seconds later it would find it.

    The only way I can fix these issues is to fully quit the apps and open them back up again, which is a massive pain to have to do every time I open the computer, especially for mail, because if I don’t specifically check the mail app I don’t realise it’s offline and miss incoming mail.

    I have tried deleting mail accounts and re-adding them but it doesn't seem to have any affect.

    Anybody else have similar problems?
     
  2. jabingla2810 thread starter macrumors 68020

    Joined:
    Oct 15, 2008
    #2
    Bugger, looks like it's just me having this issue.

    I'll give Apple a ring when I finish work.
     
  3. jabingla2810 thread starter macrumors 68020

    Joined:
    Oct 15, 2008
    #3
    Apologies for bumping an inactive thread but thought i'd add some solution incase anybody has this same problem finds this thread.

    Just got off the phone to Apple.

    He asked me to Restart in Safe Mode, go into system preferences - Energy Saving - Uncheck put hard disks to sleep when possible.

    Then go into Finder, hit Go in the menu bar and select Computer.
    Double click Macintosh HD - Library - Preferences - SystemConfiguration, and drag "com.apple.powermanagement.plist" to the trash.

    Now restart the computer into normal mode.

    Haven't had time to fully test but it seems to be working.

    If this doesn't fix the issue I'll give them another a ring and update this thread.
     

Share This Page