Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

chonazz

macrumors newbie
Original poster
Jun 25, 2014
6
1
Antwerp
Hi all,

I'm running into a problem with my father's MacBook Air. I think it's a 2019 model with intel inside.
He was doing the latest Big Sur update, but half way there was a power outage. After this the laptop stays in the update cycle.
When you restart you get the login screen where you have to fill in your password. Next you get the loading bar with a Big Sur Background for 10 seconds and then the screen goes black with a loading bar at 90%. And that's it. It doesn't complete. Even after 24 hours it's still the same.
I tried PRAM and TMC reset. The only thing this does is that the loading bar in on the black screen is not at 90% but at 10%.
I tried restarting in Safemode. (Shift). But this is incredibly slow (like almost not responding), and it only gives me the options to reinstall macOS or to Reinstall from a backup.
I think there is a firmware password installed which limited my options. But is there anything else I could try.

Thanks. Jonas
 

RomaM65

macrumors newbie
Jun 25, 2014
6
3
Ukraine, Kharkiv
Remove protection for booting from external devices, install the system on a portable media and get the necessary information. After that, reinstall Big Sure with erasing the internal ssd.
 

ipadawan

macrumors member
Aug 29, 2019
70
11
Hi all,

I'm running into a problem with my father's MacBook Air. I think it's a 2019 model with intel inside.
He was doing the latest Big Sur update, but half way there was a power outage. After this the laptop stays in the update cycle.
Hi
I got the same issue, but then without the power outage. It took a very long time to download the latest BigSur update and it also get stuk at 10%. But don't know if it did restart a second time. It sits there for half a day. Do I need tot do the same as the TS?
Could I restart the MBA or should this damage the disk or/and data? I thought I do this update then a new BackUp ( got one from two weeks ago ) then to Montgomery. But unfortunate...... here I am.

@TS did you get it working?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.