MacBook Air - Airport deactivates totally!

Discussion in 'MacBook Air' started by lars666, Jan 9, 2009.

  1. lars666 macrumors 6502a

    Joined:
    Jul 13, 2008
    #1
    Hi everybody,

    hope you're all well - I got my new MacBook Air today (Rev B, 1.6 GHz, HDD version) and need your help. I would be happy, if there wasn't a huge problem: After a few minutes, the Airport of the MBA always deactivates. Not only in the sense that I have to connect to the Internet again - the Airport is shown as deactivated/off and can't even be turned on. The Airport symbol in the menu bar gets totally blank inside. If I press "activate" in the menu bar or system preferences nothing happens. Only a reboot solves the problem - for a few minutes until it happens again.

    I've already searched the net and found out that quite a lot of people have this problem - not only on their Airs, but also on normal MacBook (Pros). Can this be caused by the heat or do you think it is a software problem? I now have to find out what to do: I almost believe this is one of those tricky hardware problems I hate - not a clear defective for warranty and not 100% reproducible - I should think about sending it back quickly in the 14 days I'm (hopefully!) able to do this without problems. Hardware or Mac OSX Software problem - if I'm not able fix this, I really have to give this baby back cause I can't work this way.

    To complete the information: I use the Time Capsule as a router on 5 GHz. I don't know if the frequency is relevant, but I don't want to change back to 2,4 GHz if the MacBook Air really can't handle this. But, as described before: It not only loses the Internet connection, it loses the whole Airport until reboot! (I have quite the same problem with Bluetooh on my iMac, by the way, but much more rarer ... I HATE those kind of problems! You are almost doomed - after frustrating trying and trying - not to find out the reason ...)

    Any help is highly appreciated. Thanks a million in advance!!! Have a nice weekend!
     
  2. jimboutilier macrumors 6502a

    Joined:
    Nov 10, 2008
    Location:
    Denver
    #2
    May be corrupted preference file

    I had that very thing happen once. While it looked like a hardware problem I talked to applecare who had me delete a system preference file. I had to configure my network stuff again but then everything worked fine after that.

    I don't remember the location or file I deleted but if you don't have applecare I can dig it up.
     
  3. lars666 thread starter macrumors 6502a

    Joined:
    Jul 13, 2008
    #3
    Hi Jimboutilier,

    thanks a lot for your answer. If you really think it is the same problem and still are able to find out how you've solved it, this would be HIGHLY appreciated, of course!!! Please let me know. Thanks!!
     
  4. lars666 thread starter macrumors 6502a

    Joined:
    Jul 13, 2008
    #4
    Was it this Airport preference file: /Library/Preferences/ SystemConfiguration/com.apple.airport.preferences.plist? I found some info in forums about it. Will try out if it works to create a new one, but I'm not confident ... Keep you informed. In the meanwhile, any other comment is appreciated!!

    EDIT: Didn't work ... :( Will try a complete new Leopard install now. Last chance ...
     
  5. lars666 thread starter macrumors 6502a

    Joined:
    Jul 13, 2008
    #5
    Okay, now I'm trying to to a clean install of Leopard on my MacBook Air here for hours and don't succeed ... I do it exactely as described here:

    http://guides.macrumors.com/Complete_Steps_to_Perform_a_Clean_OS_X_Reinstall_on_Your_MacBook_Air

    But instead of loading the installation program the MacBook always only boots from the remote disc (at least I think so) so that I end on my desktop. Have no option for "Install", even tried to press "C" like on "normal" installs. I also can't start Leopard installation after the desktop shows up although I can see and open the shared DVD. Can anybody help me out how to reach the installation menu with remote installation?? What do I do wrong?

    Sorry for mabye being a bit confusing, but it's late in the night here and these hours of trying and trying made me weak and my English worse and worse. Have to go to bed now, hope that I'll find a solution tomorrow. I AT LEAST want to be able to do a fresh install - 1. too see if this solves the Airport problem and 2. to delete my data if I have to send the notebook back.

    THANKS!!!
     
  6. zand macrumors newbie

    Joined:
    Feb 1, 2008
    #6
    Any updates here? I just got my late 2008 MBA and I have the same issues that's mentioned in this thread. Trying to figure out if I should take it back or if I can fix it myself.

    I bought a MBA the day it came out last year and used it for about half a year and I never had any problems with that one.
     
  7. TK2K macrumors 6502

    TK2K

    Joined:
    Jun 4, 2006
    #7

    This is a problem apple is aware of and they will swap out your MBA logic board if you bring it down to them. It's a hardware problem on the intel wifi chip caused by overheating.
     
  8. mathcolo macrumors 6502a

    Joined:
    Sep 14, 2008
    Location:
    Massachusetts
    #8
    Were you using the latest version of Leopard when you were having problems? (10.5.6).

    If you still have problems after reinstalling Leopard try updating to 10.5.6.
     
  9. zand macrumors newbie

    Joined:
    Feb 1, 2008
    #9
    I bought mine a couple of days ago, made sure all software updates were installed before I started using it. Since I have had problems with the airport deactivating. Tried taking it to the store today, but since they could reproduce the issue in the store they could not exchange my MBA for a new one. Once it happens again I'll just put the machine to sleep and take it to the store so they can see it for themselves and give me a new computer. The store found several unexpected airport start and stops in the system logs, but that was not enough.
     
  10. bluetooth101 macrumors newbie

    Joined:
    Feb 9, 2008
    #10
    Guys/Girls

    I have the same problem with my Airport card and bluetooth for my MBA. The unit will display a "Blank Triangle Icon and a broken bluetooth icon" whenever I on the unit.
    Sent my unit to an Apple service centre and they mentioned that either the Airport and Bluetooth cards faulty or there is problems with the logic board. They run a diagnostic and concluded that both the cards were faulty and they replaced them for me.
    Problem solved after that although I do encountered the problem sometimes. All I need to do is restart the unit and problem solved.
     

Share This Page