Macbook Air Airport not automatic

Discussion in 'MacBook Air' started by gman901, Jun 22, 2009.

  1. gman901 macrumors 6502a

    Joined:
    Sep 1, 2007
    Location:
    Houston, TX
    #1
    I really like my new MacBook Air, but one thing bothers the crap out of me which is that my airport doesn't automatically connect at home. I did nothing to my network out of the box and connect via WPA2 settings. My wife's late 2008 MacBook always connects to our home network (which is an Apple Extreme N router). Even my Dell Mini with OSX connects perfectly every time. What's causing the MacBook Air not to automatically connect and how do I fix it?

    BTW, I have tried turning off the Airport and turning back on - nope. Also I used "assist me" to reconnect my DHCP settings and clicked to automatically connect me to my network. The only way I can connect is to click down on the wireless icon and actually choose the network.
     
  2. aleksandra. macrumors 6502a

    Joined:
    Sep 13, 2008
    Location:
    Warsaw, Poland
    #2
    Do you have your network at the top of "Preferred networks" list?
     
  3. gman901 thread starter macrumors 6502a

    Joined:
    Sep 1, 2007
    Location:
    Houston, TX
  4. Sdancott macrumors regular

    Sdancott

    Joined:
    Mar 9, 2008
    Location:
    Sheffield, UK
    #4
    System Prefs>> Network >> Airport >> Advanced... >> (Airport tab) >> Is the 'Remember any network this computer has joined' box ticked?
     
  5. wetrix macrumors 6502

    wetrix

    Joined:
    Dec 1, 2006
    Location:
    Auckland, New Zealand
    #5
    My air has a similar problem, but only upon resuming from sleep. Sometimes it just doesn't join and displays the list of available networks (only one available).
     
  6. gman901 thread starter macrumors 6502a

    Joined:
    Sep 1, 2007
    Location:
    Houston, TX
    #6
    Under the advanced option, the remember network was checked and it was set to automatic. I tried also unchecking it and forcing it to only connect to my home network. Nothing seems to work. Would it be as simple as repairing disk permissions to fix the problem?
     
  7. owzer macrumors newbie

    Joined:
    Jun 23, 2009
    #7
    Something is wrong with your wireless card.
    Had the same problem with mine.
    Use to drop connections like every 5 minutes and
    you had to manually log on again or reboot.
    Took 2 trips to the store for them to fix it.
    Now it works like a charm! Love me MBA. :)
     
  8. gman901 thread starter macrumors 6502a

    Joined:
    Sep 1, 2007
    Location:
    Houston, TX
    #8
    My wireless connects automatically every time using Windows XP and when in OSX, it stays connected and never drops - but I have to manually select my network every time. Would it be a faulty wireless card if it works as I previously stated?
     
  9. sanPietro98 macrumors 6502a

    sanPietro98

    Joined:
    May 30, 2008
    Location:
    28.416834,-81.581214
    #9
    I had this problem until I turned off Bluetooth. They use the same frequency on 802.11g. Once I did this, my problems auto-connecting to my network ceased.
     
  10. gman901 thread starter macrumors 6502a

    Joined:
    Sep 1, 2007
    Location:
    Houston, TX
    #10
    So are you saying by turning off BT and turning it back on should fix it? The reason I ask is that I use a BT mouse and I really need both BT and wireless on at the same time.
     
  11. sanPietro98 macrumors 6502a

    sanPietro98

    Joined:
    May 30, 2008
    Location:
    28.416834,-81.581214
    #11
    I keep it off and only turn it on once the MBA connects to the wireless (airport) network. It's a major annoyance. But since doing that, my connection problems went away.

    I just bought the dual-band 802.11b/g/n Airport base station and plan to try that out this weekend. The 'n' band uses a different frequency than bluetooth.
     
  12. aleksandra. macrumors 6502a

    Joined:
    Sep 13, 2008
    Location:
    Warsaw, Poland
    #12
    ^ I turned BT on (never use it anyway), and my Air still connects automatically with no problems (802.11g).

    I think if it works in XP it's either a software issue (i.e. some setting we're missing or something else on this level) or a problem with that particular network. Does it work with other networks?
     
  13. gman901 thread starter macrumors 6502a

    Joined:
    Sep 1, 2007
    Location:
    Houston, TX
    #13
    Yes, it automatically connects with wife's MacBook sitting next to my Air. I think I will try repairing permissions when I get home. If all else fails, I can call Apple or just continue to manually connect. Once I am connected, I maintain solid connectivty with no dropouts.
     
  14. aleksandra. macrumors 6502a

    Joined:
    Sep 13, 2008
    Location:
    Warsaw, Poland
    #14
    What I meant was whether your MacBook Air connects automatically to other networks (if you tried it). Just because a MacBook works fine doesn't mean the problem isn't your network configuration - MBAs sometimes have issues with a particular network even though other computers (Macs included) are fine.
     
  15. zedsdead macrumors 68040

    Joined:
    Jun 20, 2007
    #15
    I had this problem with my Macbook Air. Not sure what the fix is, sorry.
     
  16. gman901 thread starter macrumors 6502a

    Joined:
    Sep 1, 2007
    Location:
    Houston, TX
    #16
    I tried resetting my Airport Extreme N router - that did not make any difference. I then repaired permissions, which also did not fix the problem. I always get a message stating that none of my "preferred networks" are available, and then it gives me somebody else's wireless router name that's nearby my house. I have to then manually click on the wifi icon up top, and then the Airport starts scanning and finds my network. Once I choose my network, I am good...it even will reconnect me after coming out of sleep mode. I guess it's not that big of a deal to manually connect one time after a reboot or startup, but I don't understand why it doesn't just automatically connect me to my network. :(
     
  17. stoconnell macrumors 6502

    Joined:
    Mar 22, 2009
    Location:
    Rockville (Despite REM's plea.)
    #17
    Have you tried deleting all your known networks and then "rediscovering" your home network? Also, there were cases where if you use a lot of wireless networks (cafes, work, etc), you want to make sure that preferred ones (home, office, etc) are the first ones in the known list.

    You can get to the list of known networks in the Advanced tab of the Airport from within Network Preferences.
     
  18. gman901 thread starter macrumors 6502a

    Joined:
    Sep 1, 2007
    Location:
    Houston, TX
    #18
    I actually contacted Apple Airport Support over the phone, and spent about 90 minutes trying a bunch of different trouble shooting steps. Nothing actually worked. At one point, we got the Airport to automatically connect for about 3 seconds, but it then dropped the connection. Apple finally told me to archive and reinstall to see if that fixes the issue. I did a clean install instead and at first, it connected automatically for about 4 seconds, then disconnected. Yesterday I updated my Apple router with the latest firmware and noticed that initially my Air connected perfectly on startup. I tested it several times, and it connected each time. Then I connected an external hard drive via USB, and noticed that my connection dropped out completely. I can't get it to connect on startup any longer. I even tried changing channels on my router, but no luck. I ultimately resolved my issue and I am much happier that I don't have to deal with the crappy wireless connectivity any longer!:)
     
  19. stoconnell macrumors 6502

    Joined:
    Mar 22, 2009
    Location:
    Rockville (Despite REM's plea.)
    #19
    I am glad that a firmware update on your airport solved your problem. I guess that explains why it was so reproducible :)
     
  20. Elgabacho macrumors newbie

    Joined:
    Jul 11, 2008
    #20
    My MBA

    I bought a new MBA on July 23 and was having problems with my Airport when waking the computer from sleep like some people who previously posted. I found this website yesterday and did some of the things suggested and so far I haven't had a problem, maybe it will help.

    http://www.macfixit.com/article.php?story=2005093011343164
     

Share This Page