MacBook Air battery draining too fast

Discussion in 'MacBook Air' started by vancexxx, Dec 4, 2013.

  1. vancexxx macrumors newbie

    Joined:
    May 16, 2008
    #1
    Hey guys,

    I bought a MacBook Air (13'', latest) a couple of days ago and it came with Mountain Lion which I only used for one battery cycle. I installed Mavericks last night and this morning I took my laptop to work, with a fully charged battery.

    It's been 1 hour since I arrived and the battery time dropped from 12:30 to 7:30, when I've only been using Safari (no more than 3 tabs open) and Mail app. Brightness is around 65%.

    Isn't this a bit too fast? When I check the battery icon, the only app that's using significant energy is Safari, so there's nothing else responsible for this, I think.

    Opinions?

    I work for 8,5 hours and I didn't bring my charger with me - since I'm only doing word processing and web browsing. I expect the battery to last me this full day of work...
     
  2. lagisibuk macrumors 6502

    Joined:
    Jun 25, 2013
    Location:
    Always Somewhere
    #2
    i'm using air haswell 13.... for office activity (browsing, document)...
    browse with many tab and also brightness 60%++
    all normal for 9-10 hours.

    FYI : i'm using mozilla :D
     
  3. vancexxx thread starter macrumors newbie

    Joined:
    May 16, 2008
    #3
    Hmm... fair enough, but then where's the estimated 12 hour battery life? Not to mention all the praises that Mavericks got, boosting the battery life to even 15 hours?
    Not to say that I'm expecting that much, but still, there's a big gap between 12 and 8.

    Well, right now, after another hour, it says 8:10, so it's not really accurate apparently. I'll see how much I end up with when the day is over.
     
  4. Robyr macrumors regular

    Joined:
    Feb 21, 2010
    #4
    Check your processes in the Activity Monitor. Sort by CPU use, and see if "kernel_task" is using 100% CPU on a core. If so, well, tough, I had to revert to Mountain Lion to fix it. Its a bug in the audio subsystem in Mavericks, and it KILLED my battery life on my 2013 Air. We're talking an easy 40% decrease.
     
  5. lagisibuk macrumors 6502

    Joined:
    Jun 25, 2013
    Location:
    Always Somewhere
    #5
    today i'm testing without music play...
    just office work (document, wifi print) and browsing (mozilla)...
    i'm start office from 8.30 - 17:00 and start work/browsing at home from 19:30 - 21:45 ... power show "24% remaining"... coool :rolleyes:

    so i'm using about 10 hours full activity...
    and 24% remaining show up to 3 hours and 27 minutes.
     
  6. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #6
    First off, I'd recommend setting the battery meter display to Percentage only. For some reason displaying time left seems stressful and brings out the OCD on you.

    Then, do a calibration, use it on batt until it gets to a single digit then go ahead and charge it overnight. Use and and see how long it lasts you in real usage, don't go by the meter so much, it's an ESTIMATE. The battery meter is not a precise instrument.
     
  7. copa macrumors member

    copa

    Joined:
    Nov 8, 2013
    #7
    crap, thats happening in my new MBA, came with mountain lion and I upgraded. What do i have to do exactly?
     
  8. Robyr macrumors regular

    Joined:
    Feb 21, 2010
    #8
    I wish I had the answer to how to fix it on Mavericks, but I ended up booting to the internet recovery mode on the Air, erased the SSD, and then it allowed me to download and reinstall Mountain Lion.

    On the same subject, it is absolutely unacceptable for this to be an issue on their current model MBAs. It would be different if it weren't a model front and center in their line up, but this is pathetic. This Air isn't even a week old, and on top of that I was so ticked off at my 2011 Air that I sold it and went to an XPS 13 but decided to give the new Haswell Air's a chance. This is souring my opinion and experience quite a bit.
     
  9. copa macrumors member

    copa

    Joined:
    Nov 8, 2013
    #9
    agreed it's somewhat diminishing the joy of using the MBA...
    I've googled some more about it at most of the time it appears to be a problem with the internal handling of the audio out up engine or something. Whenever my MBA goes to sleep with external speakers connected via the headphone jack the kernel task will ramp up to full 100% force when the machine gets woken up from sleep.

    Generally, removing the speaker cable, closing the lid, waiting a few minutes and opening up again will subdue the kernel task again. But this seems to be a cop out solution, Apple definitely has to look into this. Apparently a great number of people are affected by this, and even more probably don't know about it and wonder why their battery life is so bad.
     
  10. Robyr macrumors regular

    Joined:
    Feb 21, 2010
    #10
    Mine develops the overrun and leak pretty much any time it goes to sleep and wakes. Headphones/speakers have no bearing on the issue for me, but yes, it is definitely related to the audio subsystem, because you will see coreaudio spike and then the kernel starts ramping usage up immediately.
     
  11. copa macrumors member

    copa

    Joined:
    Nov 8, 2013
    #11
    mine now does it on other occasions as well.
    came home from university and the kernel was running at 100% when i opened it back up. Never had anything plugged in.

    :confused:
     
  12. Robyr macrumors regular

    Joined:
    Feb 21, 2010
    #12
    Yep. Sounds like a pretty major bug. The only recourse I have had thus far is a reinstall of 10.8 from the Internet Recovery.

    I am REALLY hoping this is fixed in 10.9.1, because this is an absolute failure.
     
  13. copa, Dec 5, 2013
    Last edited: Dec 5, 2013

    copa macrumors member

    copa

    Joined:
    Nov 8, 2013
    #13
    is 10.9.1 already on the horizon (ETA?)? Do we know anything about it yet?

    edit:actually now the kernel goes berserk whenever it wakes from sleep, no matter if anything was plugged in or not.
    Fiddling, as in insert and remove once, with a speaker plug in the headphone jack fixes it... but still
     
  14. CJM macrumors 65816

    CJM

    Joined:
    May 7, 2005
    Location:
    U.K.
    #14
    This is how I've been fixing it also. Removing the headphones, closing the lid and waking from sleep seems to slow the CPU back down.
     
  15. impulse462 Suspended

    impulse462

    Joined:
    Jun 3, 2009
    #15
    Check activity monitor to make sure your Mail app isn't hogging CPU usage as it does that from time to time.
     

Share This Page