MacBook Air has Internet connection, but nothing loads

Discussion in 'Mac Basics and Help' started by Tjs1993, Jan 26, 2013.

  1. Tjs1993 macrumors newbie

    Jan 26, 2013
    So, I'm currently in a dorm at a university and have been using my mac on their wifi perfectly fine since September, until this morning. I woke up and want to get on and websites wouldn't load, the blue bar would fill up like 20% of the way and sit like that forever. So I restarted my laptop, didn't work, manually plugged it in with thunderbolt Ethernet adapter, still didn't work.... I've googled this problem and tried everything I could find, manually typing the IP in, changing DNS, EVERYTHING, and it's still not anyone who has any idea how to fix this problem I would GREATLY appreciate it.
  2. FuriousMac macrumors newbie


    Jan 24, 2013
    Carolina Beach, NC
    Did you try first with an other browser ? I saw this issue 2 weeks ago.
    Reset Safari can help too
  3. JordanJ macrumors member

    Mar 10, 2012
    Check if it is limited to just your machine. Sometimes a uni network issue could be the problem
  4. estockme macrumors regular


    Mar 3, 2011
    I just started having this issue with my 2012 mba as well. I can connect fine according to the wifi icon, but nothing actually loads.
  5. estockme macrumors regular


    Mar 3, 2011
    well, i just got off the phone with applecare. we fixed it by going through the "assist me..." menu and running the diagnostic on wifi one time. Remains to be seen if this will work for my other networks but i would assume that i have somehow reset the wifi up in there.

    10.8.2 for what it's worth. Hadn't applied an update recently.

Share This Page