Macbook Air issues

Discussion in 'MacBook Air' started by Jess77, May 13, 2012.

  1. Jess77 macrumors newbie

    Joined:
    May 13, 2012
    #1
    Hi everyone,

    I have a late 2010 MBA 13" ultimate and have been having consistent problems since I purchased it.

    1.) Two weeks iTunes grey-screened and restarted the laptop a bunch of times. Called AppleCare, reset the PRAM, seemed to do the trick.
    2.) Snowy display in Safari. Beeping noises would come from the right side of the machine. AppleCare said that's impossible. Take it into the store. I took a video of it on my iPhone and showed it to the Genius at my local store and he didn't believe me, said it must be something else that was happening in the office. Said they didn't know what it could be so they just replaced my logic board.
    3.) Past two months I've been having trackpad issues (e.g. I use SPSS/Excel and when I'd go to select one column of data it would select the entire data set and move the data around...or when I'm using one finger to move the cursor, it'll right click/double click) It gets really hot on the left side of the machine and the heat moves down the left side of the keyboard. The brightness keys stopped working. Display sometimes won't turn off (it always turns off after about 15 mins of non-use). It doesn't always sit flush against my desk.

    I don't do very "intensive" things on it--Safari, iTunes, Word, SPSS. So I don't think that's an issue. Anyway, called AppleCare and they did a PRAM/SMC (?) reset and told me to go into the store because this latest issue sounds like a battery swell and it could be "dangerous" if I let it go. Went into another Apple Store and the Genius said, "Yeah, def a battery problem." Ran the tests. Nothing. Battery's fine. Even took out the battery and physically inspected it in the back. It was fine. Said they could put it through more stressful tests once I leave it overnight but don't seem confident that there could be a problem...

    I guess why I'm posting this is...have any of you experienced these problems? If so, how were they resolved? Each time I think my laptop is going to be fixed and fine, another problem comes about after, lol. I'm not angry or really frustrated (minorly frustrated, yes) but just want it to be fixed.

    Thanks in advance.
     
  2. calvol macrumors 6502a

    Joined:
    Feb 3, 2011
    #2
    Wow, a lot going on there, would think it might be power issues with the battery or voltage regulator. You might switch out the battery and see if that solves the issue. Don't know if Apple uses a VR on the battery itself or the logic board, but inconsistent voltage to the board could be causing this issue. Also, try all the recommended firmware resets and O/S reinstall. I have a 2010 MBA 13 Ult and no issues in 17 months, but I treat it like a baby.
     
  3. halledise macrumors 65816

    Joined:
    May 7, 2009
    Location:
    Hamilton Island, Whitsundays, QLD Australia
    #3
    sell it ;)
     

Share This Page