Macbook Air loses connectivity every time it sleeps.

Discussion in 'MacBook Air' started by bgent, Mar 17, 2015.

  1. bgent macrumors newbie

    Joined:
    Mar 6, 2014
    #1
    For about a month now my Macbook Air loses connectivity to wifi whenever it goes to sleep. I have it connected to my personal wifi and when I leave the MBA idle it goes to sleep after 15 mins. When I wake the computer it is still connected to my wifi, but the connectivity is gone. I have to turn airport off and then turn it back on. It regains connectivity immediately after that every time. However, it obviously shouldn't do that and it is annoying because it interrupts my downloads. I have tried playing around with the settings and reading the discussion boards. While people have had similar issues, none have been exactly the same and none of the troubleshooting has worked. Wanted to see if anyone had any suggestions or fixes for this. Thanks in advance!

    MacBook Air, OS X Mavericks (10.9.5)
     
  2. Bulldog3777 macrumors 6502

    Joined:
    Apr 2, 2009
    #2
    Wifi

    Seems to be a problem with Yosemite. Long thread on this further on back. Don't know if you are using Yosemite or earlier. Just noticed you list Mavericks at the bottom of your post.
     
  3. bgent thread starter macrumors newbie

    Joined:
    Mar 6, 2014
  4. tmarks11 macrumors 6502

    Joined:
    May 3, 2010
    #4
    Trying changing it to a fixed IP.

    Network icon... open network preferences... advanced... TCP/IP...

    Select "Use DHCP with manual address" and enter whatever your current IP address is.

    I have had similar problems before, and that has seemed to fix it.

    Then you really want to go into your router control menu, and set it up so it always assigns that laptop with that IP address.
     
  5. drsox macrumors 65816

    drsox

    Joined:
    Apr 29, 2011
    Location:
    Xhystos
    #5
    Thanks. I had the same issue but I didn't assign a fixed IP in System Preferences even though I had the AE assign the same IP address.
     

Share This Page