MacBook Air Mid 2012 Battery Problems

Discussion in 'MacBook Air' started by 184550, Oct 29, 2012.

  1. 184550 Guest

    May 8, 2008
    My mid 2012 MacBook Air (13 inch, base) will not power on or stay on without being attached to the power cord. If I unplug the cord the machine instantly dies and will not power on until I reconnect the power cord.

    The MBA indicates the battery has a 100% percent charge and coconut battery indicates the same (98% percent charge).

    I've searched the forums here and over at the Apple discussion and didn't see anything similiar to my situation.

    Any ideas what this might be? Anything I can try before scheduling an appointment at the Genius bar?

    I purchased the MBA new at Best Buy this summer if relevant.
  2. calvol macrumors 6502a

    Feb 3, 2011
    Sounds like a dead or shorted battery, or perhaps the charge controller circuit is faulty. You may try the "SMC reset" and see if that does anything. Also make sure the backside of the Air is not bulging due to a swollen battery. Try the SMC reset first, if nothing, take it down to the Genius bar.
  3. 184550 thread starter Guest

    May 8, 2008
    Thanks, I'll try the SMC reset. The outer casing appears normal.
  4. 184550 thread starter Guest

    May 8, 2008
    Tried the SMC reset a couple of times with no luck. We'll see what they say tomorrow at the Apple store.
  5. beeinformed macrumors 6502

    Jun 30, 2010

    I have a similar problem as my Macbook Air notebook (13 inch 2011 version) only works if it is attached to a wall outlet (it does not charge at all) and have sent it to Apple for repair. I was told by an Apple senior tech advisor, who has been helping me with this issue, that it could be the cable connector (which is attached to the battery and logic board) and/or it could be a component of the logic board itself.
  6. 184550 thread starter Guest

    May 8, 2008
    Just wanted to post an update incase anyone else finds this thread in the future;

    I took my MBA in this morning and the Genius ran diagnostics, reset the PRAM and tried another SMC reset. None of this helped; the MBA still immediately turned off when disconnected from a power source.

    They're going to replace the battery under warranty.

Share This Page